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1. Getting Started with the ASX Trading Terminal 

1.1. Introduction 

ASX Trading Terminal is a trade management terminal used for: 

 order entry and management 

 viewing of order and trade history 

 trading supervision purposes 

 viewing market data 

 creating User Defined Combinations. 

It can also be used by view and cancel users, who have the ability to view orders and cancel them, but not 
enter or amend them. View and cancel users are typically used for supervisory functions to monitor activity. 

To use the ASX Trading Terminal, you will need to log on the system using a valid user name, password and 
member ID. These are provided to participants by Customer Technical Support (CTS). For any questions or 
concerns contact CTS at cts@asx.com.au.  

ASX also provides information about the ASX Administration and Risk Terminal. 

1.2. User Roles 

ASX Trading Terminal users can be permissioned with a number of roles depending on the desired level of 
functionality  

User Type Allowed actions 
View 
own  

View 
all*  

Cancel 
own  

Cancel 
all*  

Enter/
replace 

View Only 

 View market data 

 Monitor orders 

 Query order and trade history  

YES NO NO NO NO 

View and 
Cancel 
User 

 View market data 

 Monitor and cancel orders 

 Query order and trade history 

YES YES YES YES NO 

Trading 
User 

 View market data 

 Enter and replace orders 

 Monitor and cancel own or 
eligible Shared orders 

 Create UDCs 

 Query order and trade history 

YES NO YES NO YES 

mailto:cts@asx.com.au
http://www.asx.com.au/services/ntp/document-library.htm
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User Type Allowed actions 
View 
own  

View 
all*  

Cancel 
own  

Cancel 
all*  

Enter/
replace 

Super 
Trading 
User 

 View market data 

 Enter and replace own orders 

 Monitor and cancel own 

 Cancel eligible shared orders or 
orders for other users within the 
firm 

 Create UDCs, query order and 
trade history 

YES YES YES YES YES 

* all users at the user’s level and below 

1.3. Version History 

This document has been revised according to the table below: 

Version Date Comment 

V2.00 July 2017 Changes for the Service Release 

 Disabling of Cancel all orders button in watchlists 

 Description of new Derivative watchlists 

 Cancellation of orders by specifying SOG 

 View only users 

V2.01 July 2017 Update to 4.2.2 on SOG behaviour when cancelling orders 

V2.02 August 2017 Added information about user roles 

V2.03 July 2023 Updated naming conventions 

 

1.4. Installing 

To install the ASX Trading Terminal, refer to the ASX Trading Terminal Installation Guide. 

1.5. Starting 

Once the ASX Trading Terminal has been installed, it can be started. 

To start the ASX Trading Terminal: 

1. Double-click the asxterminal application file to open the Login window.  

2. Enter the User ID, Password, and Member ID in the corresponding fields, and press Enter. Note that the 
User ID, Password, and Member ID are case sensitive. 

http://www.asx.com.au/documents/trading_services/ntp_terminal_installation_guidev2.pdf
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This displays the main ASX Trading Terminal screen. 

 

1.6. Exiting  

You can exit from ASX Trading Terminal by one of the following methods: 

 Click the  at the top right of the main ASX Trading Terminal screen. 

 Select File > Exit. 

 

 Press Alt + F4. 

When you exit from ASX Trading Terminal, the settings for the main screen are automatically saved and 
reloaded the next time the system is opened. 
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1.7. Locking 

Lock the ASX Trading Terminal to prevent unauthorised access when you are away from your workstation. 
You can also set a timeframe for automatic lockout. No trading activity is visible when the lock screen is on. 

To lock ASX Trading Terminal: 

 Select File > Lock Application. This displays an Application Locked dialogue box.  

 To unlock the ASX Trading Terminal, enter the required password in the Password field and click OK. 

 

To set a timeframe for automatic lockout: 

1. Select Window>Preferences from the toolbar. This opens the Preferences screen. 

2. Select General. 
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3. Select Lock and Shutdown from the General menu. This opens the Lock and Shutdown frame. 

 

4. Enter a time in the Lockout interval (minutes) field.  
If a warning is preferred before lockout, select Warning on exit or Warning on open orders. 

5. Click OK. 

1.8. Changing Password 

To change a password: 

1. Select File > Change Password.  This opens the Change Password dialogue box. 

 

2. Enter the current password and new password in the corresponding fields. 

3. Enter the new password in the Confirm Password field to confirm. 
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4. Click OK. 
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2. Navigating the ASX Trading Terminal 

2.1. Interface 

When the ASX Trading Terminal is opened for the first time it displays the Trading Overview perspective. 

A perspective provides a set of functionality aimed at accomplishing a specific type of task, or working with a 
specific type of resource. For example, the Trading Overview perspective allows the orders and trades to be 
viewed. 

A perspective contains views. For example the Trading Overview perspective contains the My Watch List 
view. 

The ASX Trading Terminal interface contains a perspective bar, toolbar, title bar and icons that can be used 
to perform functions within a perspective. 

 
Note: 

To customise the workspace including views, perspectives, colours, columns in 
tables, etc., see Customising the Workspace for more information. 

 

 

2.1.1. Views 

The layout of a perspective can be personalised by opening, closing, detaching, and docking views. 
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Views have their own menus, and some views also have their own toolbars. The actions represented by 
icons on the view’s toolbar only affect the items within that view. 

A view can appear by itself, or stacked with other views like a tabbed notebook. 

To open a view from the menus in the ASX Trading Terminal, select a view name to open the view in the 
active perspective. For example, to select the Market Trades view, select Trade > Market Trades. 

 

To open a menu for a view, click the down arrow in the view title bar and select the required option. 

 

To minimise the view, click the minimise icon on the title bar. 

 

You can also minimise a view by clicking Restore. 

To maximise a view, click the maximise icon in the view’s title bar. 
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If a view has been changed, click Restore to return to the original view. 

 

2.1.2. Title Bar 

The title bar on the ASX Trading Terminal main screen displays the application name, user, and the IP 
address. For example, [Application Name] – [User]@[IP Address]. 

 

2.1.3. Toolbar 

The main screen contains a toolbar. The Open Perspective icon enables the required perspective to be 
opened. 

 

Clicking the Open Perspective icon opens the Open Perspective dialogue box. Select the required perspective, 
and click OK. 
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2.1.4. Perspective Bar 

The perspective toolbar displays the perspectives that are currently open. Each perspective is displayed as a 
tab. The perspective that is open is highlighted. To open a perspective, click the required perspective tab. 

 

2.1.5. Icons 

The following icons are available in the ASX Trading Terminal and have the following functions. 

Icon Function 

 Enables searching. 

 
Alternatively shows and hides heartbeat events. 

 
Alternatively turns the background colours of the table rows on and off. 

 Opens the Message Details dialogue box for a selected message. 

 Alternatively freezes or unfreezes the appearance of the table. 

 
Deletes all messages. 

 
Stops the filtering of messages. 

 Filters the view based on the watch list that was selected. 

 Reverts to the last saved state. 

 
Saves the current contents. 

 
Displays every price step. 

 
Switches between the Price Ladder view and the Order Depth view. 

 Opens a dialogue box where the cancellation criteria can be selected. 

 
Cancels selected order/s on the market. 

 
Opens a menu where the required perspective can be opened. 

 
Opens a menu that enables columns to be optimised, selected, and copied. In some views 
search functionality is enabled. 
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Icon Function 

 Maximises a view within a perspective. 

 Minimises a view within a perspective. 

 Restores a view to its original size and position. 

 
This resides next to the perspective tab if the perspective contains searchable fields. 

 Opens a menu that allows a separate view to be opened on the selected watch list. 

 Opens the Inbox view where new events can be viewed. 

 
Stops new data from populating the selected window. Once Freeze is deselected any new 
data populates the window. 

 

2.2. Menus 

The main screen contains a menu bar with the following menus: 

 File 

 Order 

 RFQ 

 Trade 

 Watch List 

 Window 

 Help. 

 

2.2.1. File 

The File menu contains commands for exporting, saving changes, changing passwords, and exiting from the 
ASX Trading Terminal. 

Comments Description 

Export Excel Provides the option of Export All to Excel or Export Selected to Excel. 
This enables the data to be saved into an Excel file. 

Save Saves the current contents. 

Change Password Opens the Change Password dialogue box. 

Lock Application Locks the application immediately. 
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Exit Exits from the application. 

 

2.2.2. Order 

The Order menu contains commands for order management. 

Command Description 

Create User Defined 
Combination (UDC) 

Opens a dialogue box where the creation of UDC’s can be entered. 

Cancel Opens a dialogue box where the cancellation of orders can be 
confirmed. 

Cancel All Orders for Market Opens a dialogue box where the market can be specified for the 
cancellation of all orders. 

Cancel All Orders Opens a dialogue box where the cancellation of all orders can be 
confirmed. 

Shared Order groups Opens a dialogue box where Shared Order Group details can be 
viewed. 

Spread Matrix Opens a Spread Matrix view 

Order History Opens Order History view 

Find Active Orders Opens the Find Active Orders view. 

My Orders Ticker Opens the My Orders Ticker view. 

My Orders Opens the My Orders view. 

 

2.2.3. Request For Quote 

The Request For Quote (RFQ) menu contains commands for the request for quotes. 

Command Description 

Sent RFQ Opens the Sent RFQ view. 

Received RFQ Opens the Received RFQ view. 

Public RFQ Opens the Public RFQ view. 

 

2.2.4. Trade 

The Trade menu contains commands for trade management. 

Command Description 

Trade History Opens the Trade History view. 
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Command Description 

Trade Reports Opens the Trade Reports view. 

Market Trades Opens the Market Trades view. 

My Trades Opens the My Trades view. 

 

2.2.5. Watch List 

The Watch List menu contains commands for creating and opening watch lists. 

Command Description 

Open Opens a menu containing the names of open watch lists. 

Create Opens the New Watch List dialogue box where a new watch list can be 
created. 

Modify Watch Lists Opens the Modify Watch Lists dialogue box where watch lists can be 
renamed or deleted. 

 

2.2.6. Window 

The Window menu contains commands for opening new windows, viewing the inbox and using perspectives. 

Command Description 

Show Inbox Shows the Inbox view.  

New Window Opens a new ASX Trading Terminal window in a new Trading Overview 
perspective. 

Open Perspective Enables the required perspective to be opened. 

Save Perspective As Opens a dialogue box where a perspective can be named. 

Modify Perspectives Opens a dialogue box where you can rename or delete a defined 
perspective. 

Reset Perspectives Resets the perspective to the default settings. 

Close Perspective Closes the active perspective. 

Close All Perspectives Closes all perspectives. 

Preferences Opens the Preferences dialogue box. 

 

2.2.7. Help 

Command Description 

Display Help Displays the ASX Terminal User Guide 
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Command Description 

About Displays the name and version number of ASX Trading Terminal. 

Show Message Tracker Displays system messages. 

Show Log Displays error messages. 
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3. Managing Watch Lists 

A watch list displays summary information about order books. The type of information displayed can be 
customised. There are two types of lists: static lists where individual order books are selected, or dynamic 
lists where an underlying product type is selected. Dynamic changes will automatically reflect when new 
contracts are listed. 

 

Note: 

The maximum number of items in the watch list can be set. 

 

3.1. Creating New Watch Lists 

There are two types of watch lists that can be created: 

 Default: These contain static lists of order books. The user selects and maintains which order books 
appear in the list 

 Derivative: These contain list of order books in for underlying product types. For example, a watch list for 
ASX 90 Day Bank Accepted Bills Futures (IR) contains order books based on the IR products. This can 
include futures, options and combinations. The system automatically adjusts the list as instruments 
expire or are listed. 

3.1.1. Creating a New Default Watch List 

A new watch list can be created with only the required tradeable instruments. 

To create a new default watch list: 

1. Select Watch List > Create > Default. 

 

2. Enter the name for the new watch list in the corresponding field, and click OK.  A new view with an 
empty table appears in the active perspective. 
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3. Click in the Add instrument field. 

 

4. Enter the name of the tradeable instrument in the Add Instrument field or double-click a tradeable 
instrument from the pull-down menu. 
The tradeable instrument now appears in the table. Repeat until all of the required instruments have 
been added to the table. 

  

 

Note: 

Each tradeable instrument needs to be added individually to the new watch 
list. 

 

3.1.2. Creating New Derivative Watch Lists 

To create a new derivatives watch list: 

1. Select Watch List > Create > Derivatives. 

 

2. Enter the name for the new watch list in the dialog box and click OK. A new view with an empty table 
appears in the active perspective.  
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3. Click in the Add Underlying instrument field 

 

4. Enter the name of the underlying instrument in the Add Underlying Instrument field or double-click an 
underlying instrument from the pull-down menu. 

 
 
Repeat for all underlying instruments required. 

5. The list can be filtered by product type and number of expiry dates. To do this, right-click on any order 
book and select Content... 

 

The displayed dialog allows the following to be selected: 

 Futures - all futures contracts e.g. IRH0 

 Options - all options contracts e.g. IRH00098100C 

 Combinations - all exchange-listed spreads e.g. IRH0U0 

 Number of expiration dates - number of expiries to include, including current. Zero for all. 
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3.2. Opening Own Orders and Own Trades Watch Lists 

When an order or trade is entered for the first time, a watch list is automatically created. The watch list 
contains a list of instruments for existing orders or trades. The automatic watch lists are called Own Orders 
(for a user’s orders) and Own Trades (for a user’s trades). Any time an order or trade is created, the watch 
lists are automatically updated. 

To open the Owners Orders or Own Trades watch list, select Watch List > Own Orders or Own Trades. 

 

3.3. Renaming Watch Lists 

To rename a watch list: 

1. Select Watch Lis t> Modify Watch Lists. 

 

2. Select the name of the watch list to be renamed, and click Rename. 
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3. Enter the new name for the watch list in the corresponding field, and click OK.  
The watch list is now renamed. 

 

3.4. Deleting Watch Lists 

To delete a watch list: 

1. Select Watch List > Modify Watch List. 

 

2. Select the required watch list to be deleted. 

 

3. Click Delete. 

4. Click OK.  
The watch list is now deleted. 

3.5. Colour Coding Rows in My Watch List View 

Rows can be colour coded to increase the readability of data in the table of a watch list. The colour coding 
can also be used to group rows together. 

To colour code a row(s): 

1. Right-click the required row and select Colour Coding > Add. 

Multiple rows can be selected by Ctrl-clicking the required rows. 
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2. Select the required colour from the Colour dialogue box, or define a custom colour. 

 

3. Click OK. 

The selected colour is implemented in the watch list view. This procedure can be followed as many times 
as required to change row colours. 

 

 

3.6. Removing and Resetting Colour Coded Rows 

The colour of a row can be removed and then reset.  

To reset the colour of a row: 

1. Right-click the required row and select Colour Coding > Reset.  
This reverts any colour changes made to the row. The colour of the row can now be specified. 
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3.7. Viewing Trade Charts 

A trade chart displays the price of a tradeable instrument over a selected time period. Trade charts for a 
tradeable instrument can be viewed from any watch list. 

To view a trade chart: 

1. Right-click a row and select Trade Chart. 

 

A frame is created at the base of the screen for the selected row. It contains times on the horizontal axis 
and vertical axis. 

 

2. Hover over the horizontal axis to display a menu bar. 

 

3. Select the required option from the Chart Type pull-down menu and click Change. 

There are different options for the way in which the chart is displayed. This includes High-Low, Line, or 
Candlestick. 
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3.8. Viewing and Removing Watch List Content 

3.8.1. Viewing Tradeable Instrument Content 

A tradeable instrument can be viewed in a watch list.   

To view which groups the tradeable instruments in the current watch list are based on: 

1. Right-click the required row, and select Content. 
This displays the Watch List Content dialogue box listing available tradeable instruments. Filter results by 
entering a tradeable instrument Id in the search field. 

 

2. Click OK. 
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3.8.2. Removing Watch List Content 

All the tradeable instruments belonging to a group can be removed. 

To remove content in a watch list: 

1. Right-click on the required row in the table and click Remove.  
The Remove Tradeable Instrument dialogue box is displayed. 

  

2. Confirm that the correct tradeable instrument is being removed and click OK. This removes the 
instrument from the watch list. 

 

 

Note: 

You can also delete an item in a Watch List by selecting the required row and 
pressing Delete on the keyboard. Click OK in the Remove Tradeable 
Instrument dialogue to confirm delete. 
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4. Managing Orders 

4.1. Entering Orders 

An order can only be entered from a watch list containing tradeable instruments. If there is no watch list, 
one must be created. 

To enter an order in a watch list: 

1. Right-click a tradeable instrument and select Enter Order to display the Enter Order dialogue box. 

 

Alternatively, double-click the tradeable instrument in My Watch List to display the Enter Order dialogue 
box. 

2. Enter the price and quantity in the corresponding fields. 

3. Check the Info Fields checkbox to expand ticket and enter a valid account in the Account field 

 

4. Click either Buy or Sell. 
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4.2. Cancelling Orders 

In the event an order needs to be cancelled the follow options are available depending on the level of 
cancellations needed across the firm 

 

Note: 

Users should familiarise themselves with the various cancel options below as 
each option provides different cancelation variables depending on system and 
user requirements. Once an order has been cancelled, it is deleted from the 
system and cannot be revived. 

 

4.2.1. Cancelling an Order/Orders from My Orders View 

In the My Orders view there is the option to cancel a single order or multiple orders. 

1. To cancel a single order from My Orders view: Right-click an order in the Own Orders view and select 
Cancel. 

 

To cancel multiple orders from My Orders view: Highlight all orders required to be cancelled, Right-click 
and select Cancel. 

 

2. Click OK. 

 

Note: 

A standard User will have the ability to cancel their own orders as well as any 
order tagged with a Shared Order Group that they are a member of.  

 

4.2.2. Cancelling All Orders – Acting as a Super User under a Member 

A ‘Super User’ will be able to cancel all orders under the selected Member or Member Unit.  

To cancel all orders from the system: 

1. Select Order > Cancel… to display the Confirm Cancellation dialogue box. 
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2. Click OK. This will bring up a new window to enter cancellation criteria. 

 

3. Enter the criteria to identify the orders. The following criteria progressively filter the orders: 

 User: The user that last touched the order 

 Member: The member or member unit the user belongs to 

 Tradeable Instrument: The order book the order was placed in. 

For example, if a user and a tradeable instrument are entered, the orders for that user and tradeable 
instrument will be cancelled. Orders by the user for different tradeable instruments will not be cancelled. 

Additionally shared order groups can be used to identify orders to be cancelled. This is done by selecting All 
or Own in the Include shared orders section. This makes all the SOGs the user has access to available for 
the cancellation process. The panel below can be used to further refine the selection: 

 

Type the first few characters of the SOG and select the required SOG from the list. Repeat until all SOGs 
required are listed. 

The options identify the orders that will be cancelled: 
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 All: All orders marked with one of the selected SOGs, irrespective of the user that entered the order. If a 
user is specified in the User box, only orders in SOGs that the user specified is a member of will be 
removed.  

 Own: Orders in the selected SOGs that were last touched by the user specified in the User box 

4. Click OK. 

 

 

Note: 

To check all orders have been cancelled select the Find Active Orders window. 

 
Ensure the Tradeable Instrument field is blank and select Send. 

 
 

4.2.3. Cancelling All Orders for a User – Acting as a Super User under a Member 

A ‘Super User’ will be able to cancel all orders for a specified User under a Member or Member Unit.  

To cancel all orders for a user from the system: 

1. In the My Orders view right-click on the User heading. 

 

2. Select the User you would like to select. 
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3. Right-click an order in the Own Orders view and select Cancel. 

 

Alternatively, to cancel several orders, highlight all orders required to be cancelled and select Cancel. 

4. Click OK. 

4.2.4. Cancelling All Orders – Acting as a Super User under a Member Unit 

1. Highlight all orders in the My Orders view that are to be cancelled and select Cancel. 

 

2. Click OK. 

 

 

 

Note: 

To check all orders have been cancelled select the Find Active Orders window. 
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Ensure the Tradeable Instrument field is blank and select Send. 

 
 

4.2.5. Cancelling All Orders for a User – Acting as a Super User under a Member Unit 

A ‘Super User’ will be able to cancel all orders for a specified User under a Member Unit.  

To cancel all orders for a user from the system: 

1. In the My Orders view right-click on the User heading. 

 

2. Select the User you would like to select. 
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3. Right-click an order in the Own Orders view and select Cancel. 

 

Alternatively, to cancel several orders, highlight all orders required to be cancelled and select Cancel. 

4. Click OK. 

 

4.2.6. Cancelling Orders from My Watch List View 

ASX Trading Terminal provides the capability to cancel all orders in a user's watch list view. This functionality 
is accessed via the Cancel All Orders icon, which is disabled by default. It can be enabled by selecting the 
Enable the Cancel All Orders for the Watch List Button option in the Order Cancellation preferences. 

 

To cancel all orders for Tradeable Instruments within the User’s watch list: 

1. Click  in the main screen to display the Confirm Cancellation dialogue box.  
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2. Click OK to confirm cancellation. 

 
Warning: 

This cancels all orders from all tradeable instruments in a watch list. 

To cancel an individual order open the My Orders view, either right-click the 
order and select Cancel or select the order and press Delete on the keyboard 
and click OK. 

 

4.3. Viewing Orders 

Orders belonging to a user and all events related to such order can be viewed. All public orders in the market 
and active orders of all users of the member firm can also be viewed. Viewing orders depends on a user’s 
access rights. 

All orders can be viewed via the Order pull-down menu. This menu enables the required view to be selected. 
It appears as a tab in a new window. 

 

 

 

4.3.1. Viewing your own Orders 

To view your own orders, select Order > My Orders to display the My Orders view. 

4.3.2. Viewing Every Event in an Order 

To view your own orders, select Order > My Orders to display the My Orders view. My Orders shows orders 
you have entered and orders in any Shared Order Groups (SOGs) you have access to. 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 37/140  
 

In circumstances where a SOG is modified, the client maybe unable to correctly update the status of orders. 
When this occurs, the system displays the dialog shown below advising the user to restart. 

 

 

Note: 

If the My Orders Ticker view is in the background when the ASX Trading Terminal is opened, it 
will not start subscribing to order events until it is brought into the foreground. Once it has been 
brought into the foreground it can then be returned to the background where it will continue to 
subscribe. 
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4.3.3. Viewing all Public Orders in the Market 

To view all public orders in the market in a view, select Order > Market Order Ticker. This opens the Market 
Order Ticker view. 

 

4.3.4. Viewing all Active Orders for Users of Member Firm 

To view all active orders for all users of a member firm, select Order > Find Active Orders. This opens the 
Find Active Orders view. 
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4.3.5. Viewing details of your own Orders 

 At times, you may need to view your own order details, for example the validity of an order. 

To view a user’s own order details: 

1. Select Order > My Orders from the Trading perspective. 

2. Right-click the required order and select Details. This opens the Details dialogue box containing the 
details of the order. 

 

3. Click OK.  
Once the details of the order have been viewed, click OK. 
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4.4. Updating Orders 

Orders that have been entered can be updated from either the My Orders, Order Depth, or Price Ladder 
view. To update an order from the Price Ladder view, drag and drop the order’s ask or bid quantity to the 
price in the price ladder. 

4.4.1. My Orders View 

To update an order from the My Orders view: 

1. Right-click a tradeable instrument in the My Orders view, and select Update Order. 

 

2. Update the order and click Buy or Sell.  
The appropriate button is highlighted depending on whether it is a Buy or Sell order. 
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4.4.2. Order Depth View 

To update an order from the Order Depth view: 

1. In the watch list, right-click the tradeable instrument to update and select Order Depth Ladder. 

 

2. Change the required values in the Bid Qty and Ask Qty columns in the Order Depth view.  
The order is displayed in bold. 

 

 

Note: 

If a quantity is changed in the order but the order is not required to be 
updated, select [Esc]. 
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4.5. Viewing Order Depths 

The Order Depth Ladder contains two views; Order Depth and Price Ladder view. Each of these views show 
different price levels for a specific tradeable instrument.  

 The Order Depth view shows the actual prices of all orders.  

 The Price Ladder view shows aggregated order levels.  

If a user has their own orders that add to the levels, they are shown in the Own columns. The ladders are 
updated in real time. 

To see the Price Ladder view, right-click on a contract (tradeable instrument) in the required watch list and 
select Order Depth Ladder.  

 

In this view, click the  icon, on the top right of the window, to switch between Order Depth Ladder and 

Price Ladder views. 

 

Note: 

A watch list must be open to view the order depths. 

 

To view the order depth ladder, right-click the required tradeable instrument in the watch list and select 
Order Depth Ladder. The depth ladder for the selected tradeable instrument appears in the active 
perspective. 
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4.6. User Defined Combinations (UDCs) 

User Defined Combinations (UDCs) replace Custom Market functionality. UDCs can be created with up to 6 
legs and depending on the contracts selected, generally have net premium pricing.  One leg (generally the 
futures leg of an FO) can be fixed.   

4.6.1. Entering UDC Orders 

An order can be entered into a UDC by dragging and dropping a tradeable instrument from the watch list or 
by typing in the code of the instrument in the entry field.  

To enter an order in a UDC: 

1. To create a UDC, select Order > Create User Defined Combination. The Create User Defined 
Combination dialogue is displayed. 

  

2. Type the contract name in the top entry field. Alternatively, drag and drop the first tradeable instrument 
in your watch list that will be part of the UDC, directly into the Leg field. 

3. Complete the Ratio and Buy/Sell fields.  

4. Repeat for each additional leg of the Strategy: 

a. Select a Fixed price for a fixed price strategy by double clicking in the fixed price field and entering a 
valid price. 

b. For a net price strategy, enter the net price in the Net Price field. 

5. Add in a quantity, if releasing an order immediately. Leave price as zero/blank, if just creating a strategy. 

6. Select Send/Pay or Send/Receive depending on the strategy direction for an outright order. 
7. For Pre Negotiated Orders, select Request Quote. If a UDC can be created as specified by the user, an 

RFQ for the newly created UDC is sent to the market. If a functionally identical UDC can be created (e.g. 
with all buy legs instead of all sell legs) the UDC will be created, but the RFQ will not be sent. If the UDC 
already exists, an RFQ will also not be sent. 
 
Participants must wait the prescribed period of time before crossing the pre-negotiated trade. Further 
details on usage and operation of UDCs can be found in the ASX 24 User Defined Combination document. 
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4.6.2. Joining a created UDC  

1. Type UDC into the add instrument field of the watch list. All created UDCs will appear. 

2. Double-click the UDC name in the drop down list to add it the watch list. 

 

3. Once added to the watch list, enter an order as described in the Order Entry procedure. 
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4.7. Spread Matrix 

A spread matrix can be used to enter Intra Spreads directly into the trading system. 

4.7.1. Entering Orders via the Spread Matrix 

To enter an order in a UDC

1. To open the Spread Matrix, select Order > Spread Matrix. The spread Matrix Tab appears in the Inbox 
section of the main screen 

   

2. Drag The Tab outside of the main screen to make the Spread Matrix a floating window. For greater 
visibility, drag it to a separate screen. 

3. Click the Instrument drop down arrow to open all Instruments available within the Spread Matrix 

 

4. Select an instrument to display all available expiries in the Matrix. 

5. Double-click the relevant field to enter orders either into the Outright Market or the spread markets. 

6. Complete the order entry ticket as described in the Order Entry section. 
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Note, outright Prices are highlighted in a bold colour, and implied prices are highlighted in a light colour. 
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5. Managing Requests for Quotes 

Requests for Quotes (RFQs) can be managed in the following ways: 

 Sending RFQs 

 Cancelling RFQs 

 Viewing RFQs 

 Responding to RFQs. 
 

5.1. Sending RFQs 

Public requests can be sent for bid and ask quotes. RFQs can be sent from a watch list with tradeable 
instruments. If there is no watch list then one will need to be created. 

To send an RFQ: 

1. Right-click a tradeable instrument in a watch list and select Request Quote. 

 

2. Select the required item from the Side pull-down menu. 
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3. Enter the quantity in the Qty field. 

 

4. Click OK.  The RFQ appears in the Request For Quotes frame. 

 
 

5.2. Cancelling an RFQ 

To cancel an RFQ: 

1. Select RFQ > Sent RFQ. 

 

2. Right-click the required trade and select Cancel Request For Quote. 
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5.3. Viewing RFQs 

A user’s RFQs can be viewed from the RFQ menu. This includes RFQs that have been sent and received. 

Public RFQs can also be viewed from the Inbox view. 

5.3.1. Viewing public RFQs 

To view a public RFQ: 

3. Select Requests For Quotes from the Inbox view. 

 

4. Select Show View next to the quote to display additional details for the Public RFQ view. 

 

 

5.3.2. Viewing Sent RFQs 

To view a sent RFQ, select RFQ > Sent RFQ, or click the Sent RFQ tab. 
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6. Managing the Message Tracker 

Message Tracker can be used to view the system. The Message Tracker view displays all messages that have 
been sent to and from ASX Trading Terminal. The messages are displayed in chronological order and are 
updated every time a message is sent or received. 

6.1. Viewing System Messages 

To view system messages, select Help > Show Message Tracker. The Message Tracker view is displayed in 
the active perspective at the base of the screen. 

 

6.1.1. Saving System Messages to a File 

To save system log messages to a physical location in real time, you need to enable the Start Logging To File 
feature. The system messages will then appear in the Message Tracker view and in a file on the user’s hard 
drive. 

To save system messages to a file: 

1. Select Help > Show Message Tracker.  
This displays the messages in the Message Tracker tab at the base of the screen. 

 

5. Click the down arrow to the right of the view name and select Start logging To file. 
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A log file is created in the location where ASX Trading Terminal is installed, typically this is located in 
workspaces > user name > Metadata folder. 

 

Once Start logging To file has been selected, the table on the Message Tracker view is cleared. However, 
this table will be repopulated with messages as soon as the logging has started. The logging continues 
until a user exits from ASX Trading Terminal. 

 

 
  



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 52/140  
 

6.2. Managing Display Filter for System Messages 

System messages can be filtered and displayed in the Message Tracker view. 

To apply a filter: 

1. Select Help > Show Message Tracker. 

 

2. Enter the required text to be displayed in the table in the search field on the right of the frame.  
The wildcard characters ? or * can be used, if required. 

 

To clear a filter, click the Clear Filter icon at the right of the screen. 

 

6.3. Freezing or Unfreezing System Message Display 

As the table in the Message Tracker view is continuously updated it may be necessary to freeze the contents 
of the table to view messages. 

To freeze or unfreeze the system message display: 

1. Select Help > Show Message Tracker. 

2. Click Freeze/Unfreeze icon located in the right corner of the window. 
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6.4. Copying System Messages 

Selected messages or all messages can be copied in the Message Tracker view. 

To copy selected messages: 

1. Select Help > Show Message Tracker. 

2. Select the required messages in the table. To select multiple messages, hold down the Ctrl key. 

3. Click the down arrow in the right side of the frame and select Copy > All to copy contents of the selected 
message. 

 

6.5. Clearing System Messages 

To clear system messages: 

1. Select Help > Show Message Tracker. 

2. Click the Clear Table icon on the right corner of the window. 
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6.6. Viewing System Message Details 

System message details can be viewed in the message tracker. 

To view the system message details: 

1. Select Help > Show Message Tracker. 

2. Double-click a message or select the required message and click Details.  
This displays the Message Details dialogue box for the selected message where details can be viewed. 

 

3. Click OK. 

 

 

Note: 

If Details is selected to open the Message Details dialogue box and then 
another message is selected, the latest message selected appears in the 
Message Details dialogue box. This is not possible if the Message Details 
dialogue box was opened by double-clicking the message. 
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6.7. Managing the Display Filter for System Message Details 

The system messages in the Message Details dialogue box can be filtered.  

To apply a filter: 

1. Select Help > Show Message Tracker. Double-click the required message or select the required message 
and click Details.  
This displays the Message Details dialogue box for the selected message. 

 

2. Enter the required filtering text in the available field.  
The wildcard characters ? or * can be used, if required. To clear the filter, select Clear Filter.  
To expand the list to include all of the information, click Expand All.  
To only display the message name, click Collapse All. 

 

3. Click OK. 

When all of the required message details have been viewed, click OK to exit. 

  



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 56/140  
 

6.8. Changing System Message Background Colours 

Messages can be displayed either on an only white background or with rows coloured as yellow, grey, or 
white. The coloured background reflects the type of message displayed. 

When background row colours are on, the colours mean the following: 

 Yellow – Requests to the server process from ASX Trading Terminal 

 Grey – Responses from the server process from ASX Trading Terminal 

 White– All other types of messages. 

 

Note: 

If the background colours are not on, then all of the rows in the table will be 
white. 

To change message backgrounds: 

1. Select Help > Show Message Tracker. 

2. Click Colours On/Off.  
The background will switch between white and colour depending on the currently selected setting. 

 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 57/140  
 

7. Viewing Market Messages 

Market messages generated during the current business day are displayed immediately after they have been 
sent. They are visible in the Market Messages sub view of the Inbox view. They are listed in time-priority 
order. 

All messages are displayed as a single line. If messages are longer than a single line, the additional 
information can also be viewed. 

To view market messages: 

1. Select the Market Messages tab in the Inbox view.  
The Market Message sub view is displayed. 

 

2. For messages with more than one line, click Details to the right of the message.  
This opens the Details dialogue box with the details of the selected message. 

Note that additional details will only be visible for messages that contain more than one line. 
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8. View and Dialogue Boxes 

Views and dialogue boxes provide the means to perform various trading functions in the ASX Trading 
Terminal. These are listed below in alphabetical order and include explanations of the specific functionality. 

8.1. Cancel Order Dialogue Box 

To open the Cancel Order dialogue box: 

1. Select Order > Cancel. 

 

 
2. Click OK. 

  

Option Description 

Orders Enables an order to be cancelled. 

User User ID of the logged in user. 

Member The ID of the member. 

Tradeable Instrument The name of the tradeable instrument. 

 

8.2. Details Dialogue Box 

1. Select the required order in the My Orders screen, right-click and select Details. 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 59/140  
 

 

 

Attribute  Value 

Hide Empty Rows If selected, only attributes with a value are displayed. 

Account Ask Side The name of the ask side account. 

Account Bid Side The name of the of the bid side account. 

Buy/Sell Indicates whether the trade is a buy or sell trade. 

Buy Member User’s Member ID 

Buy User The ID of the buying user. 

Comb Trade Id The Trade ID field of the combination trade that is the source of this 
trade. 

Corresponding Price The corresponding price of the trade. If there is an alternative way 
to express the price of a traded instrument, this value is calculated 
by the system. An example is a traded bond where the 
corresponding price is a yield. 

Counter Party Clearing The counterparty member responsible for clearing the order. 
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Attribute  Value 

Member Note: This field is only filled if the current market transparency 
allows for it. 

Counter Party Owner Type The owner type of the counterparty side of the trade. It can be one 
of the following: 

 Customer 

 Principal. 

Note: This value is only visible if the current market transparency 
allows for it. 

Counter Party Trading 

Member 

The ID of the counterparty participant's sponsoring member. 

Note: This field is only completed if the current market transparency 
allows for it. 

Counter Party User The ID of the counterparty user. 

Note: This field is only completed if the current market transparency 
allows for it. 

Deal ID The deal ID for the trade. 

High The day's highest registered price for the tradeable instrument. 

Id The ID assigned to each individual trade. It is unique both over time 
and within the ASX 24 Trading Platform. 

Is Aggressor This defines a side of a trade (buy, sell, or both sides) and if the side 
is exploiting liquidity in the book. Which side is the aggressor 
depends on trading phase, order type, marketplace price model etc. 
The normal case is that an incoming order (aggressor) hits a resting 
order in the book (passive). 

The following values are possible: 

• Yes 

• No. 

Last Auction Price The last recorded auction price for the tradeable instrument.  

Low The day's lowest registered price for the contract. 

Own Account Information about a user’s own account. 

Own Clearing Member The member who is responsible for clearing the order. 

Own Info Text Information text for a user’s side of the trade. 

Own Member The Member ID for the user’s side of the trade. 

Own Message Ref Message text about the trade. 

Own Owner Type The type may be either: 

 Customer 

 Principal. 
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Attribute  Value 

Own Private Order Id The ID of an order on the private flow. The ID is unique both over 
time and within the system. 

Own Trading Member The own participant's sponsoring member. 

Own User The user ID of the trade. 

Price The price of the trade. 

Qty The volume of the trade. 
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8.3. Enter Order Dialogue Box 

To open the Enter Order dialogue box, right-click an item in the required watch list and select Enter Order 
from the Oder menu. 

  

Option  Description 

Buy Used to enter or update a buy order. 

Note: Buy is only available if the order is a buy order. 

Open Qty The open order volume (chunk size). 

Info Fields Informational only for this release. 

Price The price of the order. The highest priority property used for deciding the 
priority of the order. 

Price Band The price band method used. Price bands control prices to ensure they are not 
moving too fast in any direction. The price band has a dynamic and a static 
interval where the dynamic interval can move inside the static. 

Price Type The following value is allowed: 

 Limit: Specifies the highest bid price (for a buy order) or lowest ask 
price (for a sell order) that the order owner is willing to accept. 

 Market to Level: No price is set only volume, a buy order will hit the 
best offer (for a sell order vice versa). 

Quantity The original order volume. 

Sell Used to enter or update a sell order. 

Note: Sell is only available if the order is a sell order. 
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Option  Description 

Validity The length of time for the order to be valid. The following values are allowed: 

 Day: The order is valid until the end of the current trading day 

 Fill and Kill: 

o If the order is entered in automatch, as much as possible of the order is 
filled and the remainder is cancelled 

o If the order is entered in non-automatch, the order remains until the next 
uncross. In the uncross, as much as possible is filled and the remainder is 
cancelled. 

 Fill or Kill: 

o If the order is entered in automatch, the order is filled entirely or is 
cancelled. 

o If the order is entered in non-automatch, the order remains until the next 
uncross. In the uncross, the full volume is traded or the order is cancelled. 

 Good till Cancel: The order never expires. 

 More: The dialogue box expands to show conditions concerning the 
validity of the order. For an explanation of the conditions and their 
values refer to the tables below. 
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8.3.1. Valid From Conditions and Values 

To see the Valid From frame, select More from the Validity pull-down menu. 

 

Select the required option from the Valid From Condition pull-down menu. 

 

Option Description Value 

Intermediate The normal default condition. The order is 
immediately entered into the market. 

NA 

Time The order is entered into a suspended state but 
automatically activated at a future time. The time 
must be within the current day. 

hh:mm:ss 

Next Auction The order will be entered into the next uncross book. 
The order will participate in the next uncross and will 
be moved into the central book at that time. 

NA 

Next Automatch The order is valid from the next automatch. NA 

Session The order will be kept in a separate book until the 
order book reaches the specified state. The order will 
then be entered into the main book before any 
uncross is performed. 

Dependent on the state 
of the order book. 

8.3.2. Valid Till Conditions and Values 

Select the required option from the Valid Till Condition pull-down menu. 
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Option Description  Value 

Next Match The order is valid until the next match. NA 

Next Auction The order is valid until the next uncross (auction). NA 

Next Automatch The order is valid until the next automatch. NA 

Session The order is valid until the order book reaches the 
specified state. 

Dependent on the state of 
the order book. 

Time The order is valid until the time specified in Value. 
This time must be within the current trading day. 

hh:mm:ss 

Day The order is valid until the end of the current 
trading day. 

NA 

Date The order is valid until the date specified in Value. mm/dd/yyyy 

Cancel The order is valid until it is cancelled. NA 
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8.3.3. Info Fields 

To display the info fields select Info Fields. 

  

There are seven different fields where information can be entered. 

Field Description 

Account The name of the account. 

Clearing Member To filter for orders related to a specific clearing member, either 
specify the name of the clearing member or use the Find dialogue 
box to find and enter the clearing member name. 

Info Where additional information can be added. 

Reference Used at the discretion of the client application. The recommended 
usage for this field is to include end user data. 

Clearing Account Used at the discretion of the client application. The recommended 
usage for this field is to include end user data. 

Account Type Either Customer or non-Customer can be tagged to an order 

Shared Order Group Used to specify the preconfigured Shared Order Group the user 
wants this order assigned to. 
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8.3.4. Price Band Fields 

To open the Price Band frame, select Price Band. 

   

Field Description 

Break The calculated upper and lower break price band. 

Inner Break The calculated upper and lower inner break price band. 

Dynamic The calculated upper and lower dynamic price band. 

Static The calculated upper and lower static price band. 
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8.4. Error Log View 

To display the error log, select Help > Show Log. 

      

 

The error log appears at the bottom of the screen. 

Icon Description 

 
Exports the Error Log to a location on a user’s computer. 

 
Imports a log from a location on your computer. The button lets you browse your 
computer for a log to import. Click the down-arrow to view a list of available logs to 
import. 

 
Clear Log Viewer button. Clears the current log records from the Error log 
perspective. 

 Delete Log button. Deletes the current log from your computer. 

 
Open Log button. Opens the current log in a viewer (for example TextPad). 

 
Reload Workspace Log button. 
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8.5. Find Active Orders View 

To open the Find Active Orders view, select Order > Find Active Orders. 

 

 

Field Description 

Tradeable Instrument The name of the tradeable instrument in the Tradeable 
Instrument field to be included in the search. 

 

Column Description 

Accept Order Id ID of an order using accept matching, instead of automatic 
matching. 

Account The name of the account. 

Actual Price The actual price of the order. 

Additional Event Contains additional information about the type of event. 

Buy/Sell Indicates whether the order is a buy or sell order. 

Cancel On Logout This value can be either True or False. If True, all orders are 
cancelled when exiting from the application. 

Clearing Member To filter for orders related to a specific clearing member, either 
specify the name of the clearing member or use the Find dialogue 
box to find and enter the clearing member name. 

Corresponding Price The corresponding price of the trade. If there is an alternative 
way to express the price of a traded instrument, this value is 
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Column Description 

calculated by ASX Trading Terminal. An example is a traded bond 
where the corresponding price is a yield. 

Event An event can be one of the following: 

 INSERT: The order is new, not traded yet. 

 CANCEL: The order is fully traded, or cancelled by its 
owner, or it has expired. 

 UPDATE:  The order is partially traded, or price 
recalculated, or quantity refilled, or modified by its 
owner. 

Info Text Any additional information. 

Is Suspended This value can be either True or False. If True, the order is 
suspended. 

Is Valid for Trading Select if the tradeable instrument is to be valid for trading. 

Long Order Date Date set by the system when the order is stored as a long order. 

Note: It changes every time an order is stored in the long-order 
database. 

Matched Qty Indicative auction volume. The quantity is zero if there is no 
auction price available. 

Member Identifies the member that the user belongs to. A member can 
have a number of users associated with it. Users within the same 
member can access each other’s orders assuming that they have 
adequate authorisation. A user always has a subset of the 
member’s authorisation. 

Message Ref Message about the order. 

Minimum Condition A volume condition for an order. It can have the following values: 

 NONE: The order has no volume restriction. It can match 
any volume. 

 MULTIPLE_ORDERS: The order has a minimum volume 
restriction; however, it is allowed to be filled with several 
different orders as long as the aggregated traded volume 
matches the minimum volume condition. The orders can 
have different price levels. 

Minimum Quantity The minimum volume that this order has to match. For an 
all-or-none order, this value is the same as the total order 
volume. 

Open Qty The open order volume (chunk size). 

Order Ref Used at the discretion of the client application. The 
recommended usage for this field to include end user data. 

Org Qty The original volume of the tradeable instrument. 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 71/140  
 

Column Description 

Owner Type This can have one of the following values: 

 CUSTOMER 

 PRINCIPAL. 

Price The actual price of the order. 

Price Condition Determines how the order is priced. The price condition can have 
the following value: 

 LIMIT: The order can be executed at the specified price 
or better. 

Private Id The ID of an order on the private flow. The ID is unique both over 
time and within the system. 

Public Member The order member info that can be seen by the public. 

Note: This field is only filled out if the current market 
transparency allows for it. 

Qty The volume of an order. 

Source of Event The origin of an event. The source of an event can be any of the 
following: 

 USER: Explicit action taken by a user 

 SYSTEM: Action taken by the system 

 OPERATOR: Action performed by a user. 

Source of Event User ID of the user specified in Source of Event. 
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Column Description 

Sub Event Indicates with a greater level of detail the type of event. 

 CANCEL_DUE_TO_PRICEBAND: Order broke price band 
criteria and was cancelled. 

 CANCEL: User cancelled order 

 EXPIRED: Order expired 

 FILLED: Complete fill of an order that has occurred 

 INSERT: User registers new order 

 MASSACTIVATED: Order was activated as part of a mass 
activation transaction 

 MASSCANCEL: Order was cancelled as part of a mass 
cancel transaction 

 NO_BASE_PRICE: Some type of reference price used by 
the order was not available. A typical example is an order 
pegged to an external price reference. 

 PARTIALLYFILLED: Partial fill of an order occurred 

 RESTORE_VALIDATION_FAILED: Restore of overnight 
order failed validation. 

 RESTORE: Overnight orders are restored by the system in 
the morning. 

 SAVEDOVERNIGHT: Order was cancelled as it was saved 
overnight. The order will be restored on the next trading 
day. 

 UPDATE: User updated order 

 USERDELETED: Order was cancelled due to the user 
being deleted. 

 USERDISABLED: Order was cancelled due to the user 
being disabled. 

 USERDISCONNECTED: Order was cancelled as the user 
was disconnected. Orders are individually marked as 
being eligible for cancellation in case of disconnect. 

 WOULDHAVECROSSED: Depending on the configuration 
of the system it may disallow crosses within a market 
participant. 

Time of Entry The time that the order was inserted. 

Time of Modification The time of a modification to an order. If there is no modification 
this value is equal to the time of entry. 

Tradeable Instrument The name of the tradeable instrument. 
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Column Description 

Trading Member If the member is part of a hierarchy then this field contains the 
parent member. If the member is not part of a hierarchy then 
this field is set to be identical to the member. 

Type There is only one type of order - Single Order (a single-sided 
order). 

Unsolicited Message An output message not associated with an input message. It 
results from a host application sending an unsolicited message. 

User The ID of the user. 

Valid Duration Length of time for an order to remain valid. 

The following values are allowed: 

 Day: The order is valid until the end of the current trading 
day 

 Fill and Kill: 

o If the order is entered in automatch, as much as possible 
of the order is filled and the remainder is cancelled. 

o If the order is entered in non-automatch, the order 
remains until the next uncross. In the uncross as much as 
possible is filled and the remainder is cancelled.  

 Fill or Kill: 

o If the order is entered in automatch, the order is filled 
entirely or is cancelled. 

o If the order is entered in non-automatch, the order 
remains until the next uncross. In the uncross, the full 
volume is traded or the order is cancelled. 

 Good till Cancel: The order never expires. 

 More: The dialogue box expands to show conditions 
concerning the validity of the order. For an explanation 
of the conditions and their values, see Valid From and 
Valid Till descriptions. 

Valid From An order can have one of the following Valid From values: 

 Immediate: The order is immediately entered into the 
market. 

 Time: The order becomes inactive until the specified 
time has passed. The time is always relative to the 
current day, and if the time has passed, the order is 
activated immediately. The time is specified in Valid 
From Desc. 

Valid From Desc Specifies from what time (in the format HH:mm:ss) a 
GOOD_FROM_TIME order is active. 
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Column Description 

Valid Till An order can have one of the following valid-till conditions: 

 Next Match: The order is valid till it has had one chance of 
matching. During automatch, the order therefore behaves 
like a fill or kill or a fill and kill order. During an auction 
phase, this condition is not valid and the order will be 
rejected. 

 Time: The order expires automatically when the specified 
time has been reached. The time is always relative to the 
current day, and if the time has passed, then the order is 
cancelled immediately. The time, in the format HH:mm:ss, 
is specified in Valid Till Desc. 

 Next Auction: The order is cancelled when the next 
auction session is entered. If the current session is an 
auction, then the order is cancelled immediately. 

 Next Automatch: The order is cancelled when the next 
automatch session starts. This means that the order is 
valid during auction sessions. If the current session is in 
automatch, then the order is cancelled immediately. 

 Session: The order is cancelled when the specified session 
starts. If the current session has the specified name, then 
the order is immediately cancelled. If a session with the 
specified name has already passed during the current 
session cycle, then the order remains and waits for the 
next session with the specified name. The session name is 
specified in Valid Till Data. 

 Day: The order is good for the remaining part of the 
trading session. 

 Date - The order is valid until a specified date. The date is 
specified in Valid Till Data. 

 Cancel: The order is valid until explicitly cancelled. 

Valid Till Desc Specifies till what time (in the format HH:mm:ss) a 
GOOD_TILL_TIME order is active. 
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8.6. Market Messages Subview in Inbox View 

The information in bold is the time the message was sent. The second row contains the market message. 

 

8.7. Market Trades View 

To open the Market Trades view, select Trade > Market Trades. 

  

Column Description 

Buy Member ID of the member the buying user belongs to. 

Corresponding 

Price 

Corresponding price of the trade. If there is an alternative 
way to express the price of a traded instrument, this value is 
calculated by ASX Trading Terminal. An example is a traded 
bond where the corresponding price is a yield. 

Deal ID ID of the deal this trade is part of. 

Note: A deal is defines as all trades generated by a single 
event. An event is, for example an incoming order or an 
uncross. Therefore all trades resulting from the same event 
will have the same deal number. 

High The day's highest registered price for the tradeable 
instrument. 

Last Auction Price The last recorded auction price for the tradeable instrument. 

Low The day's lowest registered price for the contract. 

Price The price of the trade. 

Quantity (Qty) The original order volume. 

Sell Member The ID of the member that the selling user belongs to. 

Sub Trade Type The subtypes of trade are: 

 AUCTION - Auction execution 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 76/140  
 

Column Description 

 AUTO - Deprecated; anything but trade report 

 MANUAL_LAST_AUCTION - Manual set of last auction 
price 

 MANUAL_LAST_REFERENCE - Manual set of last 
reference price 

 MANUAL_LAST_TRADE - Manual set of last trade price 

 TRADE_REPORT - Trade report execution 

 TRANSPARENT_TO_TRANSPARENT - Execution of two 
transparent orders. 

Time Of Trade Time for the trade to take place. 

Total Turnover Total turnover for trades executed during the trading day. 

Total Volume Traded Total volume for trades executed during trading day. 

Tradeable Instrument The name of the tradeable instrument. 

Trade ID The ID assigned to each individual trade. It is unique both 
over time and within ASX Trading Terminal. 

Trade Type The following types of trade are available: 

 BUSTED – A busted trade, that is, a cancelled trade. 

 NEW - A new trade. 

 TRADE_REPORT_HALF - Half of a trade report (not a 
complete trade). This type is received only on private 
flows. 

 UPDATED - Update of a trade with the same trade ID 
or deal ID as the original trade. This type is received 
only on private flows. 

Update Last Paid The following values are allowed: 

 Yes - The trade is allowed to update LastTradePrice. 

 No - The trade is not allowed to update 
LastTradePrice. 
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8.8. Message Details Dialogue Box 

 

Element Description 

Field to the left of Clear Filter Filters the details to be displayed. 

Clear Filter Clears the text in the field to the left of Clear Filter. 

Expand All Expands the tree structure in the dialogue box. 

Collapse All Collapses the tree structure in the dialogue box. 

Show When selected, the dialogue box shows the row even though it 
does not contain a value. 

Key Name of data fields in the object message (the top level of the tree 
structure) and name of the object class (the branches in the tree 
structure) respectively. 

Value Value of each object and class. 
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8.9. Message Tracker View 

To open the Message Tracker view, select Help > Show Message Tracker. The Message Tracker is displayed 
at the base of the screen. 

  

Columns Description 

Time The time when the message was sent to or received from the TAX 
server process. 

Type Type of message: 

 TAX Req - Requests to the TAX server process from ASX 
Trading Terminal. 

 TAX Rsp - Responses from the TAX server process to ASX 
Trading Terminal. 

 UC - Unicast messages. They are unsolicited messages 
received from the TAX server process as a result of a 
subscription. 

Name Name of message, as described in the EMAPI specification. 

Status Status of message. It can be either OK or a text string describing 
what went wrong. 

Note: Only messages of the type TAX Rsp and messages of type UC 
with the name EmapiTaxEndSnapshot have a status value. 

Flow ID of the subscription flow that is associated with the specific 
message.  

Note: Only message of the type UC have a flow. 
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8.10. My Orders View 

To open the My Orders view, select Order>My Orders. 

 

 

Column Description 

Accept Order Id ID of an order using accept matching instead of automatic matching. 

Account Name of the account. 

Acting User Logged-in user; the user who established the session. 

Note: This field may deviate from the normal user field in case of on behalf. 

Actual Price Actual price of the order. 

Additional Event Contains additional information about the type of event. 

Buy/Sell Indicates whether the order is a buy or sell order. 

Cancel On Logout Can be either True or False. If True, all orders are cancelled when the 
application is exited. 

Clearing Member To filter for orders related to a specific clearing member, either specify the 
name of the clearing member or use the Find dialogue box to find and enter 
the clearing member’s name. 

Client Defined Quote ID The ID assigned by the client. It is possible to relate a trade to a specific 
quote with this ID. 

Corresponding Price The corresponding price of the trade. If there is an alternative way to 
express the price of a traded instrument, this value is calculated by ASX 
Trading Terminal. An example is a traded bond where the corresponding 
price is a yield. 

Event An event can be one of the following: 

 INSERT - The order is new, not traded yet. 
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Column Description 

 CANCEL - The order is fully traded, or cancelled by its owner, or it has 
expired. 

 UPDATE - The order is partially traded, price recalculated, quantity 
refilled, or modified by its owner. 

Info Text Any additional information. 

Is Valid for Trading Select if the tradeable instrument is to be valid for trading. 

Long Order Date This date is set by the system when the order is stored as a long order. 

Note: The date changes every time an order is stored in the long order 
database. 

Matched Qty Indicative auction volume. The quantity is zero if there is no auction price 
available. 

Member Identifies the member that the user belongs to. A member can have a 
number of users associated with it. Users within the same member can 
access each other’s orders assuming that they have adequate authorisation. 
A user always has a subset of the member’s authorisation. 

Message Ref Message about the order. 

Minimum Condition A volume condition for an order. It can have the following values: 

 NONE - The order has no volume restriction. It can match any volume. 

 MULTIPLE_ORDERS - The order has a minimum volume restriction; 
however, it is allowed to be filled with several different orders as 
long as the aggregated traded volume matches the minimum 
volume condition. The orders can have different price levels. 

Minimum Qty The minimum volume that this order has to match. For an  
all-or-none order this value is the same as the total order volume. 

Open Qty Open order volume (chunk size). 

Order Price Price of the order. The highest priority property used for deciding the 
priority of the order. 

Order Ref Used at the discretion of the client application. The recommended usage for 
this field to include end user data. 

Org Qty Original volume of the tradeable instrument. 

Owner Type This can have one of the following values: 

 CUSTOMER 

 PRINCIPAL. 

Price Condition Determines how the order is priced. The price condition can have the 
following value: 

 LIMIT - The order can be executed at the specified price or better. 

Private Id The ID of an order on the private flow. The ID is unique for both over time 
and within the system. 
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Column Description 

Public Member The order member info that can be seen by the public. 

Note: This field is only filled out if the current market transparency allows 
for it. 

Qty The volume of an order. 

Source of Event This describes the origin of an event. The source of an event can be any of 
the following: 

 USER - Explicit action taken by a user 

 SYSTEM - Action taken by the system 

 OPERATOR - Action performed by an operator. 

Source of Event User ID of the user specified in Source of Event. 

Sub Event This indicates with a greater level of detail the type of event. 

 CANCEL_DUE_TO_PRICEBAND - Order broke price band criteria 
and event was cancelled 

 CANCEL - User cancelled order 

 EXPIRED - Order expired 

 FILLED - Complete fill of an order occurred 

 INSERT - User registers new order 

 MASSACTIVATED - Order was activated as a part of a mass 
activation transaction 

 MASSCANCEL - Order was cancelled as a part of a mass cancel 
transaction 

 NO_BASE_PRICE - Some type of reference price used by the order 
was not available. 

 PARTIALLYFILLED - Partial fill of an order occurred 

 RESTORE_VALIDATION_FAILED - Restore of overnight order that 
failed validation. 

 RESTORE - Overnight orders are restored by the system in the 
morning 

 SAVEDOVERNIGHT - Order was cancelled since it was saved 
overnight. The order will be restored the next trading day. 

 UPDATE - User updated order 

 USERDELETED - Order was cancelled due to the user being 
deleted. 

 USERDISABLED - Order was cancelled due to the user being 
disabled. 

 USERDISCONNECTED - Order was cancelled due to the user being 
disconnected. Orders are individually marked as being eligible for 
cancellation in case of a disconnect. 
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Column Description 

 WOULDHAVECROSSED - System can depending on configuration 
disallow crosses within a market participant. 

Time of Entry Time that the order was inserted. 

Time of Modification Time any modification of the order, if any. If there is no modification, this 
value is equal to the time of entry. 

Tradeable Instrument The name of the tradeable instrument. 

Trading Member If the member is part of a hierarchy then this field contains the parent 
member. If the member is not part of a hierarchy then this field is set to be 
identical to the member. 

Type There is one type of order - Single Order (a single-sided order). 

Unsolicited Message An unsolicited message is an output message not associated with an input 
message. It results from a host application sending an unsolicited message. 

User The ID of the user. 

Valid Duration The length of how long the order is required to be valid. The following values 
are allowed: 

 Day: The order is valid until the end of the current trading day 

 Fill and Kill: If the order is entered in automatch, as much as possible 
of the order is filled and the remainder is cancelled. If the order is 
entered in non automatch, the order remains until the next uncross. 
In the uncross, as much as possible is filled and the remainder is 
cancelled. 

 Fill or Kill: If the order is entered in automatch, the order is filled 
entirely or is cancelled. If the order is entered in non automatch, the 
order remains until the next uncross. In the uncross, the full volume 
is traded or the order is cancelled. 

 Good till Cancel: The order never expires. 

 More:  The dialogue box expands to show conditions concerning the 
validity of the order. For an explanation of the conditions and their 
values, see Valid From and Valid To. 

Valid From An order can have one of the following Valid From values: 

 Immediate - The order is immediately entered into the market 

 Time - The order becomes inactive until the specified time has passed. 
The time is always relative to the current day, and if the time has 
passed, the order is activated immediately. The time is specified in 
Valid From Desc. 

Valid from Desc Specifies from what time (in the format HH:mm:ss) a GOOD_FROM_ TIME 
order is active. 

Valid Till An order can have one of the following Valid Till conditions: 
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Column Description 

 Next Match: The order is valid till it has had one chance of matching. 
During automatch, the order therefore behaves like a fill or kill or a 
fill and kill order. During an auction phase, this condition is not valid 
and the order will be rejected. 

 Time:  The order expires automatically when the specified time has 
been reached. The time is always relative to the current day, and if 
the time has passed, then the order is cancelled immediately. The 
time, in the format HH:mm:ss, is specified in Valid Till Desc. 

 Next Auction:  The order is cancelled when the next auction session is 
entered. If the current session is an auction, then the order is 
cancelled immediately. 

 Next Automatch - The order is cancelled when the next automatch 
session starts. This means that the order is valid during auction 
sessions. If the current session is in automatch, then the order is 
cancelled immediately. 

 Session:  The order is cancelled when the specified session starts. If 
the current session has the specified name, then the order is 
immediately cancelled. If a session with the specified name has 
already passed during the current session cycle, then the order 
remains and waits for the next session with the specified name. The 
session name is specified in Valid Till Data. 

 Day:  The order is good for the remaining part of the trading session. 

 Date:  The order is valid until a specified date. The date is specified in 
Valid Till Data. 

 Cancel: The order is valid until explicitly cancelled. 

Valid Till Desc Till what time (in the format HH:mm:ss) a GOOD_TILL_TIME order is active. 
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8.11. My Orders Ticker View 

To open the My Orders Ticker view, select Order > My Orders Ticker. 

  

Columns Description 

Accept Order Id ID of an order using accept matching, instead of automatic 
matching. 

Account Name of the account. 

Acting User Logged-in user; the user who established the session. 

Note: This field might deviate from the normal user field in case of 
on-behalf. 

Actual Price Actual price of the order. 

Additional Event Additional information about the type of event. 

Buy/Sell Indicates whether the order is a buy or sell order. 

Cancel on Logout This value can be either True or False. If True, all orders are 
cancelled when exiting the application. 

Clearing Member To filter for orders related to a specific clearing member, either 
specify the name of the clearing member or use the Find dialogue 
box to find and enter the clearing member name. 

Corresponding Price Corresponding price of the trade. If there is an alternative way to 
express the price of a traded instrument, this value is calculated 
by ASX Trading Terminal. An example is a traded bond where the 
corresponding price is a yield. 

Event An event can be one of the following: 

 INSERT - The order is new, not traded yet. 

 CANCEL - The order is fully traded, cancelled by its owner, 
or it has expired. 

 UPDATE - The order is partially traded, price recalculated, 
quantity refilled, or modified by its owner. 

Info Text Any additional information. 

Is Valid For Trading Selected if the tradeable instrument is to be valid for trading. 
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Columns Description 

Long Order Date This date is set by the system when the order is stored as a long 
order. 

Note: This changes every time an order is stored in the 
long-order database 

Member Identifies the member that the user belongs to. A member can 
have a number of users associated with it. Users within the same 
member can access each other’s orders assuming that they have 
adequate authorisation. A user always has a subset of the 
member’s authorisation. 

Message Ref Message about the order. 

Minimum Condition A volume condition for an order. It can have the following values: 

 NONE - The order has no volume restriction. It can match 
any volume. 

 MULTIPLE_ORDERS - The order has a minimum volume 
restriction; however, it is allowed to be filled with several 
different orders as long as the aggregated traded volume 
matches the minimum volume condition. The orders can 
have different price levels. 

Minimum Quantity The minimum volume that this order has to match. For an all-or-
none order, this value is the same as the total order volume. 

Open Qty The open order volume (chunk size). 

Owner Type This can have one of the following values: 

 CUSTOMER 

 PRINCIPAL. 

Price The actual price of the order. 

Price Condition Determines how the order is priced. The price condition can have 
the following value: 

 LIMIT - The order can be executed at the specified price or 
better. 

Private Id The ID of the order on the public flow. This ID is unique within the 
system and over time. 

Public Member The order member info that can be seen by the public. 

Note: This field is only filled out if the current market 
transparency allows for it. 

Qty The volume of an order. 

Source of Event This describes the origin of an event. The source of an event can 
be any of the following: 

 USER - Explicit action taken by a user 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 86/140  
 

Columns Description 

 SYSTEM - Action taken by the system 

 OPERATOR - Action performed by an operator. 

Source of Event User ID of the user specified in Source of Event. 

Sub Event This indicates with a greater level of detail the type of event. 

 CANCEL_DUE_TO_PRICEBAND - Order broke price band 
criteria and was cancelled 

 CANCEL - User cancelled order 

 EXPIRED - Order expired 

 FILLED - Complete fill of an order occurred 

 INSERT - User registers new order 

 MASSACTIVATED - Order was activated as part of a mass 
activation transaction 

 MASSCANCEL - Order was cancelled as part of a mass 
cancel transaction 

 NO_BASE_PRICE - Some type of reference price used by the 
order was not available 

 PARTIALLYFILLED - Partial fill of an order occurred 

 RESTORE_VALIDATION_FAILED - Restore of overnight 
order failed validation 

 RESTORE - Overnight orders are restored by the system in 
the morning 

 SAVEDOVERNIGHT - Order was cancelled since it was saved 
overnight. The order will be restored the following trading 
day. 

 UPDATE - User updated order 

 USERDELETED - Order was cancelled due to the user being 
deleted 

 USERDISABLED - Order was cancelled due to the user being 
disabled 

 USERDISCONNECTED - Order was cancelled as the user was 
disconnected 

 Orders are individually marked as being eligible for 
cancellation in case of a disconnect. 

 WOULDHAVECROSSED - System can, depending on 
configuration, disallow crosses within a market 
participant. 

Time of Entry The time that the order was inserted. 

Time of Modification The time any modification of the order, if any. If there is no 
modification, this value is equal to the time of entry. 
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Columns Description 

Tradeable Instrument The name of the tradeable instrument. 

Trading Member If the member is part of a hierarchy then this field contains the 
parent member. If the member is not part of a hierarchy then this 
field is set to be identical to the member. 

Type There is one type of order - Single Order (a single-sided order). 

Unsolicited Message An unsolicited message is an output message not associated with 
an input message. It results from a host application sending an 
unsolicited message. 

User The ID of the user. 

Valid Duration The length for the order to be valid. The following values are 
allowed: 

 Day - The order is valid until the end of the current trading 
day 

 Fill and Kill 

 If the order is entered in automatch, as much as possible of 
the order is filled and the remainder is cancelled. 

 If the order is entered in non automatch, the order remains 
until the next uncross. In the uncross, as much as possible is 
filled and the remainder is cancelled. 

 Fill or Kill 

 If the order is entered in automatch, the order is filled 
entirely or is cancelled. 

 If the order is entered in non automatch, the order remains 
until the next uncross. In the uncross, the full volume is 
traded or the order is cancelled. 

 Good till Cancel - The order never expires. 

 More - The dialogue box expands to show conditions 
concerning the validity of the order. For an explanation of 
the conditions and their values, which appear under Valid 
From and Valid To. 

Valid From An order can have one of the following valid-from values: 

 Immediate - The order is immediately entered into the 
market. 

 Time - The order becomes inactive until the specified time 
has passed. The time is always relative to the current day, 
and if the time has passed, the order is activated 
immediately. The time is specified in Valid From Desc. 

Valid from Desc This specifies from what time (in the format HH:mm:ss) a 
GOOD_FROM_TIME order is active. 
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Columns Description 

Valid Till An order can have one of the following Valid Till conditions: 

 Next Match - The order is valid till it has had one chance of 
matching. During automatch, the order therefore behaves 
like a fill or kill or a fill and kill order. During an auction 
phase, this condition is not valid and the order will be 
rejected. 

 Time - The order expires automatically when the specified 
time has been reached. The time is always relative to the 
current day, and if the time has passed, then the order is 
cancelled immediately. The time, in the format HH:mm:ss, 
is specified in Valid Till Desc. 

 Next Auction - The order is cancelled when the next auction 
session is entered. If the current session is an auction, then 
the order is cancelled immediately. 

 Next Automatch - The order is cancelled when the next 
automatch session starts. This means that the order is valid 
during auction sessions. If the current session is in 
automatch, then the order is cancelled immediately. 

 Session - The order is cancelled when the specified session 
starts. If the current session has the specified name, then 
the order is immediately cancelled. If a session with the 
specified name has already passed during the current 
session cycle, then the order remains and waits for the next 
session with the specified name. The session name is 
specified in Valid Till Data. 

 Day - The order is good for the remaining part of the 
trading session. 

 Date - The order is valid until a specified date. The date is 
specified in Valid Till Data. 

 Cancel - The order is valid until explicitly cancelled. 

Valid Till desc This specifies till what time (in the format HH:mm:ss) a 
GOOD_TILL_TIME order is active. 

 

8.12. My Trades View 

To open the My Trades view, select Trade>My Trades. 
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Column Description 

Account Ask Side The name of the ask side account. 

Account Bid Side The name of the bid side account. 

Buy Member The ID of the member the buying user belongs to. 

Buy User The ID of the buying user. 

Buy/Sell Indicates whether the trade is a buy or sell trade. 

Comb Trade Id If the trade is a part of a combination trade, this field contains the value 
of the Trade ID field of the combination trade; that is the source of the 
trade. 

Corresponding Price The corresponding price of the trade. If there is an alternative way to 
express the price of a traded instrument, this value is calculated by ASX 
Trading Terminal. An example is a traded bond where the 
corresponding price is a yield. 

Counter Party Clearing 
Member 

The counterparty member responsible for clearing the order. 

Note: This field is only filled out if the current market transparency 
allows for it. 

Counter Party Member The ID of the counterparty member. 

Note: This field is only filled out if the current market transparency 
allows for it. 

Counter Party Owner Type The owner type of the counterparty side of the trade. 

It can be one of the following: 

 CUSTOMER 

 PRINCIPAL. 

Note: This value is only visible if the current market transparency allows 
for it. 

Counter Party Trading Member The ID of the counterparty participant's sponsoring member. 

Note: This field is only filled out if the current market transparency 
allows for it. 
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Column Description 

Counter Party User The ID of the counterparty user. 

Deal ID The ID of the deal the trade is part of. 

Note: A deal is defined as all trades generated by a single event. An 
event is, for example, an incoming order or an uncross. Therefore all 
trades resulting from the same event will have the same deal number. 

Id The ID assigned to each individual trade. It is unique both over time 
and within the ASX 24 Trading Platform. 

Is Aggressor Defines a side of a trade (buy, sell, or both sides). It defines if the side is 
exploiting liquidity in the book. Which side is aggressor depends on 
trading phase, order type, marketplace price model, etc? The normal 
case is that an incoming order (aggressor) hits a resting order in the 
book (passive). 

Possible values are Yes/No. 

Own Account Information about a user’s own account. 

Own Clearing Member The own member who is responsible for clearing the order. 

Own Info Text Information text for your own side of the trade. 

Own Member The ID of the member that you belong to (your side of the trade). 

Own Message Ref Message text about the trade. 

Own Owner Type This can have one of the following values: 

 CUSTOMER 

 PRINCIPAL. 

Own Private Order Id The ID of an order on the private flow. The ID is unique both over time 
and within the system. 

Own Trading Member The own participant's sponsoring member. 

Own User The ID of the user. 

Price The price of the trade. 

Qty The volume of the trade. 

Receiving Member Counterparty member who receives a copy of the trade report half. 

Reference Trade ID The reference trade ID is used to tie two trades together. It can be used 
to tie related trades together and to connect a busted trade with its 
replacement trade. 

Sell Member The ID of the member that the selling user belongs to.  

Sell User The ID of the selling user. 
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Column Description 

Sub Trade Type The subtypes of trade are: 

 AUCTION - Auction execution 

 AUTO - Deprecated; anything but trade report 

 MANUAL_LAST_AUCTION - Manual set of last auction price 

 MANUAL_LAST_REFERENCE - Manual set of last reference price 

 MANUAL_LAST_TRADE - Manual set of last trade price 

 TRADE_REPORT - Trade report execution 

 TRANSPARENT_TO_TRANSPARENT - Execution of two 
transparent orders. 

Time of Event The time when the event took place.  

Time of Trade The time for the trade to take place. 

Total Turnover The total turnover for trades executed during the trading day. 

Total Volume Traded The total volume for trades executed during the trading day. 

Tradeable Instrument The name of the tradeable instrument. 

Trade Type The following types of trade are available: 

 BUSTED – A busted trade, that is, a cancelled trade. 

 NEW - A new trade. 

 TRADE_REPORT_HALF – A half of a trade report (not a complete 
trade). This type is received only on private flows. 

 UPDATED - An update of a trade with the same trade ID or deal 
ID as the original trade. This type is received only on private 
flows. 

Update Last Paid The following values are allowed: 

 Yes - The trade is allowed to update LastTradePrice. 

 No - The trade is not allowed to update LastTradePrice. 
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8.13. My Watch List View 

To open the My Watch List view, select Watch List > Open > My Watch List. 

 

Column Description 

Ask Price The ask price. 

Ask Qty The ask volume. If a quote is matched, the default value appears here.  

Bid Price The bid price. 

Bid Qty The bid volume. If a quote is matched, the default value appears here. 

High Price The day's highest registered price for the tradeable instrument. 

Last Paid The last paid price for the tradeable instrument. 

Low Price The day's lowest registered price for the instrument. 

Name The name of the instrument. 

Open Price The days first registered price for the instrument. 

Own Ask Displays own ask order quantity. Can be used to place or update ask 
order. 

Own Bid Displays own bid order quantity. Can be used to place or update bid 
order. 

State The trading state of the instrument. 

Turnover The total turnover of the instrument, measured as Price times Volume. 

Total Qty The Total traded volume/quantity of the instrument, measured as lots 
executed. 
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8.14. Options View 

To open the Options view, select Watch List > Instrument > Options. 

 

Column Description 

Last Trade Latest trade price paid for the tradeable instrument. 

BBO Best bid offer for a particular tradeable instrument. 

Expiration Date the contract expires.  

Call BBO Bid Best bid offer for a bid call option. 

Call BBO Ask Best bid offer for a ask call option. 

Strike Price at which the owner of the option can buy or sell. 

Put BBO Bid Best bid offer for a bid put option. 

Put BBO Ask Best bid offer for an ask put option. 
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8.15. Order Depth View 

To open the Order Depth view, right-click on the item in the watch list and select Order Depth Ladder. 

 

 

 

 

Note: 

Click  to switch between Order Depth view and Price Ladder view. 

 

Columns Description 

Bid Qty Bid volume. 

Bid Price The bid price. 

Ask Price The ask price. 

Ask Qty Ask volume. If a quote is matched, the default value appears here. 

Show Every Tick Shows every price step. 
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8.16. Order Details Dialogue Box 

To open the Order Details view, right-click on the required order and select Details. 

 

 

Columns Description 

Hide Empty Rows If selected, only attributes with a value are displayed. 

Accept Order Id ID of an order using accept matching, instead of automatic matching. 

Account The name of the account. 

Acting User This is the logged-in user; the user who established the session. 

Note: This field might deviate from the normal user field in case of on-
behalf. 

Actual Price The price of the order. The highest priority property used for deciding 
the priority of the order. 

Additional Event Optional. Contains additional information about the event type.  

Buy/Sell Indicates whether the order is a buy or sell order. 

Cancel On Logout This value can be either True or False. If True, all orders are cancelled 
when exiting from the application. 
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Columns Description 

Clearing Member To filter orders related to a specific clearing member, either specify the 
name of the clearing member or use the Find dialogue box to find and 
enter the clearing member name. 

Corresponding Price The corresponding price of the trade. If there is an alternative way to 
express the price of a traded instrument, this value is calculated by the 
ASX 24 Trading Platform. An example is a traded bond where the 
corresponding price is a yield. 

Event An event can be one of the following: 

 INSERT - The order is new, not traded yet 

 CANCEL - The order is fully traded, or cancelled by its owner, or 
it has expired 

 UPDATE - The order is partially traded, or price recalculated, or 
quantity refilled, or modified by its owner. 

Info Text Any additional information. 

Is Valid for Trading Select if the tradeable instrument is to be valid for trading. 

Long Order Date This date is set by the system when the order is stored as a long order. 

Note: It changes every time an order is stored in the long-order 
database. 

Member Identifies the member that the user belongs to. A member can have a 
number of users associated with it. Users within the same member can 
access each other’s orders assuming that they have adequate 
authorisation. A user always has a subset of the member’s 
authorisation. 

Message Ref Message about the order. 

Minimum Condition A volume condition for an order. It can have the following values: 

 NONE - The order has no volume restriction. It can match any 
volume. 

 MULTIPLE_ORDERS - The order has a minimum volume 
restriction; however, it is allowed to be filled with several 
different orders as long as the aggregated traded volume 
matches the minimum volume condition. The orders can have 
different price levels. 

Minimum Qty The minimum volume that this order has to match. For an 
all-or-none order, this value is the same as the total order volume. 

Open Qty The open order volume (chunk size). 

Order Ref Used at the discretion of the client application. The recommended 
usage for this field to include end user data. 

Org Qty The original order volume. 

Owner Type This can have one of the following values: 
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Columns Description 

 CUSTOMER 

 PRINCIPAL. 

Price The price of the order. The highest priority property used for deciding 
the priority of the order. 

Private Id The ID of an order on the private flow. The ID is unique both over time 
and within the system. 

Public Id The ID of the order on the public flow. This ID is unique within the 
system and over time. 

Public Member The order member info that can be seen by the public. 

Note: This field is only filled out if the current market transparency 
allows for it. 

Public Order Id The ID of the order on the public flow. This ID is unique within the 
system and over time. 

Qty The volume of an order. 

Source of Event This describes the origin of an event. The source of an event can be 
any of the following: 

 USER - Explicit action taken by a user 

 SYSTEM - Action taken by the system 

 OPERATOR - Action performed by an operator. 

Remaining Open Quantity Displays the public volume. For example, if an iceberg order is entered 
with the quantity 50 and open quantity 10, this shows 10. 

Remaining Original Quantity The volume of an order. 

Source of Event User ID of the user specified in Source of Event. 

Sub Event This indicates with a greater level of detail the type of event. 

 CANCEL_DUE_TO_PRICEBAND - Order broke price band criteria 
and was cancelled 

 CANCEL - User cancelled order 

 EXPIRED - order expired 

 FILLED - Complete fill of an order occurred 

 INSERT - User registers new order 

 MASSACTIVATED - Order was activated as a part of a mass 
activation transaction 

 MASSCANCEL - Order was cancelled as a part of a mass cancel 
transaction 

 NO_BASE_PRICE - Some type of reference price used by the 
order was not available 

 PARTIALLYFILLED - Partial fill of an order occurred 
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Columns Description 

 RESTORE_VALIDATION_FAILED - Restore of overnight order 
failed validation 

 RESTORE - Overnight orders are restored by the system in the 
morning 

 SAVEDOVERNIGHT - Order was cancelled since it was saved 
overnight. The order will be restored next trading day. 

 UPDATE - User updated order 

 USERDELETED - Order was cancelled due to that the user was 
deleted 

 USERDISABLED - Order was cancelled due to that the user was 
disabled 

 USERDISCONNECTED - Order was cancelled as the user was 
disconnected. Orders are individually marked as being eligible 
for cancellation in case of a disconnect 

 WOULDHAVECROSSED - System can depending on 
configuration disallow crosses within a market participant. 

Time of Entry The time for the order to take place. 

Time of Modification The time any modification of the order, if any. If there is no 
modification, this value is equal to the time of entry. 

Tradeable Instrument The name of the tradeable instrument. 

Trading Member If the member is part of a hierarchy then this field contains the parent 
member. If the member is not part of a hierarchy then this field is set 
to be identical to the member. 

Type There is one type of order - Single Order (a single-sided order). 

Unsolicited Message An unsolicited message is an output message not associated with an 
input message. It results from a host application sending an unsolicited 
message. 

User The ID of the logged on user. 

Valid Duration The length of time the trade report is required to be valid. The time is 
measured in seconds. If a time is not specified, the trade report is 
assumed to be valid until cancelled or matched. Most system 
configurations discard unmatched trade halves at the end of day, 
regardless of validity time. 
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Columns Description 

Valid From An order can have one of the following Valid From values: 

 Immediate - The order is immediately entered into the market 

 Time - The order becomes inactive until the specified time has 
passed. The time is always relative to the current day, and if the 
time has passed, the order is activated immediately. The time is 
specified in Valid From Desc. 

Valid From Desc This specifies from what time (in the format HH:mm:ss) a 
GOOD_FROM_TIME order is active. 

Valid Till An order can have one of the following Valid Till conditions: 

 Next Match - The order is valid till it has had one chance of 
matching. During automatch the order behaves like a fill or kill 
or a fill and kill order. During an auction phase, this condition is 
not valid and the order will be rejected. 

 Time - The order expires automatically when the specified time 
has been reached. The time is always relative to the current day, 
and if the time has passed, then the order is cancelled 
immediately. The time in the format HH:mm:ss, is specified in 
Valid Till Desc. 

 Next Auction - The order is cancelled when the next auction 
session is entered. If the current session is an auction, then the 
order is cancelled immediately. 

 Next Automatch - The order is cancelled when the next 
automatch session starts. This means that the order is valid 
during auction sessions. If the current session is in automatch, 
then the order is cancelled immediately. 

 Session - The order is cancelled when the specified session 
starts. If the current session has the specified name, then the 
order is immediately cancelled. If a session with the specified 
name has already passed during the current session cycle, then 
the order remains and waits for the next session with the 
specified name. The session name is specified in Valid Till Data. 

 Day - The order is good for the remaining part of the trading 
session. 

 Date - The order is valid until a specified date. The date is 
specified in Valid Till Data. 

 Cancel - The order is valid until explicitly cancelled. 

Valid Till Desc This specifies till what time (in the format HH:mm:ss) a 
GOOD_TILL_TIME order is active. 
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8.17. Preferences Dialogue Box 

In the Preferences dialogue box it can be decided how data is presented (for example, the text size or the 
colours of various phases of traded orders). The appearance of the dialogue box varies depending on what 
area the preference settings is set for. 

To open the Preferences dialogue box, select Window > Preferences. 

 

 

8.17.1. General Option 

The General option from the menu on the left side of the dialogue box contains all of the settings for the 
general appearance of the windows in ASX Trading Terminal. 

The General option can also be selected to display additional options. 

 

Items Description 

Filter Field Filters the appearance of the tree structure. 

Always run in background When selected, all long-running processes, such as setting up 
subscriptions to instruments, continue to run in the 
background and a user can continue working as usual. 
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Items Description 

Keep next/previous editor, view and 
perspective dialogue open 

When selected, the shortcut key combinations CTRL + F7 and 
CTRL + F8 opens a small window that allows a user to select 
an open view or perspective. When this is not selected, the 
shortcut key combinations work as a switch between either 
views or perspectives and a small window is not displayed 
where the view or perspective can be selected. 

Show heap status When selected, the Java heap status is displayed. This is used 
for troubleshooting. 

Workbench save interval (in minutes) How frequently the workbench is saved in minutes. 

Open mode Sets how resources are opened in ASX Trading Terminal. This 
can either be a double-click or single click. Note that this 
preference may not take effect on all views. 

Restore Defaults Restore Defaults changes all settings in the selected option 
to the original settings. For example, if the double-click is 
changed to single click, if Restore Defaults is selected, this 
setting returns to double-click. 
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Colours and Fonts 

 
 

Items Description 

Filter Field Filters the settings that a user wants to appear in the frame below it. 
For example, if a user wants to see the settings for members, 
member can be typed in the box. 

Enter Order Folder Contains settings for how to colour code price input and quantity 
input. 

Notifications and Alerts Folder Contains settings for changing colours of notifications that are sent 
within the application. 

Spread Matrix Contains settings for changing colours of notifications that are sent 
within the Spread Matrix. 

Trading Folder Contains settings for changing colours of order states. 

Description When a setting is highlighted, a description of the setting is 
displayed in this area. 

Preview When a setting is highlighted, a preview of what will be changed is 
displayed in this location. 
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Table Settings 

 
 

Items Description 

Background Colour Specifies the background colour in tables. 

Foreground Colour Specifies the foreground colour in tables. 

Font Specifies the font used in tables. Click Change to make changes to the 
displayed font. 

Header Visible When selected, column headers are displayed in tables.  

Lines Visible When selected, lines are displayed in tables. 
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Keys 
 

 
 

Items Description 

Command Identifies the action to be assigned a function key. 

Binding Specifies the function key assigned to the command. 

Category Specifies the category the action belongs to. 
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Lock and Shutdown Settings 

 

 

Item Description 

Lockout interval 

(minutes) 

This time decides for how long ASX Trading Terminal is inactive before 
being automatically locked. 

Warning on exit When selected, ASX Trading Terminal sends a warning before exiting the 
application. 

Warning on open orders When selected, ASX Trading Terminal sends a warning before exiting the 
application if there are any open orders. 
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Security Settings 

 

Note: 

The security settings can be more or less available depending on user’s security clearance on the 
New Trading System. 

 
 

Tab Description 

Password  This tab contains settings for a user’s password. 

Contents This tab contains settings for storage locations of various security settings. 

Advanced This tab contains a list of encryption algorithms. 
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Settings – Confirmation 

 

 

Item Description 

Confirmation Allows different confirmation parameters to be 
set. 
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Settings – Ticker 

 

 

Items Description 

Maximal number of items Defines a maximum number of items a ticker can contain. 
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Settings – Watch List Price Levels 

 

Field  Description 

Maximum price levels Defines a maximum price level for a watch list. 
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8.18. Properties for Dialogue Boxes 

 

 

Field Description 

Background Colour Sets the background colour of the table in the view. 

Foreground Colour Sets the font colour of the table. 

Font Displays the used font for the table. 

Change Opens a dialogue box that lets you change the font. 

Header Visible Select or deselect header visible as required. 

Lines Visible Select or deselect lines visible as required. 
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8.19. Public RFQ View 

To open the Public RFQ view, select RFQ>Public RFQ.  

 

 

Field Description 

Buy/Sell Indicates whether the RFQ is for a buy or sell quote. The following values are 
possible: 

 Ask Request 

 Bid Request 

 Bid and Ask Request. 

Event Type The type of event. The following values are possible: 

 INSERT - Insertion of a new RFQ. The RFQ data contains data of the 
new RFQ. 

 CANCEL - Cancellation of an RFQ. The RFQ data contains data of the 
RFQ as it looked at the time of cancellation. 

Public Id The RFQ ID. 

Public Member The order member info that can be seen by the public. 

Type The type is RFQ. 
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8.20. Received RFQ View 

This view shows received requests for quotes for a specific watch list or for all markets. By right-clicking a 
user can: 

 Enter trade half 

 Choose which received RFQs to be seen. 

To open the Received RFQ view, select RFQ>Received RFQ. 

 

 

Item Description 

Distribution The following value(s) are possible: 

 PUBLIC - The request for quote is distributed to all members 
having access to the relevant order book. 

 PRIVATE - The RFQ is distributed only to a specified member. 

Member  Identifies the member that the user belongs to. A member can have 
a number of users associated with it. Users within the same member 
can access each other’s orders assuming that they have adequate 
authorisation. A user always has a subset of the member’s 
authorisation. 

Public Id The RFQ ID. 

Qty The requested quantity. 

Quote Provider Member The member who is asked to provide a quote. 

Receiving Member The member who receives the request for quote. 
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Item Description 

Request Type The following types of RFQs are available: 

 Ask 

 Bid 

 Bid and Ask. 

Tradeable Instrument The name of the tradeable instrument. 

 

8.21. Send RFQ Message Dialogue Box 

In the required watch list, right-click the required tradeable instrument and select Request Quote. 

  

Item Description 

Side Select either Ask & Bid, Bid, or Ask. 

Qty The requested quantity. 
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8.22. Sent RFQ View 

To open the Sent RFQ view, select RFQ>Sent RFQ. 

 

 

Item Description 

Distribution The following value(s) are possible: 

 PUBLIC - The RFQ is distributed to all members having access to the 
relevant order book. 

 PRIVATE - The RFQ is distributed only to a specified member. 

Member Identifies the member that the user belongs to. A member can have a 
number of users associated with it. Users within the same member can 
access each other’s orders assuming that they have adequate 
authorisation. A user always has a subset of the member’s authorisation. 

Public Id The RFQ ID. 

Qty The requested quantity. 

Quote Provider Member The member who is asked to provide a quote. 

Receiving Member The member who receives the request for quote. 

Request Type The following types of RFQs are available: 

 Ask 

 Bid 

 Bid and Ask. 

Tradeable Instrument The name of the tradeable instrument. 

 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 115/140  
 

8.23. Trade History View 

 

Filters 

Filter Description 

Tradeable Instrument Enter the name of a tradeable instrument to view trades for. 

Trade Id Enter the ID of the trade to view. 

Deal Id Enter the ID of the deal to view trades for. 

From Enter the beginning of the search time span. 

To Enter the end of the search time span. 

Size Select the number of trades to be displayed. 

Own Select to search for own trades only. 

Include Units Select the checkbox to find trades entered by member unit users. 

Reset Clears the search criteria. 

Send Submits the search criteria. 
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Column Descriptions 

Column Description 

Account Ask Side The name of the ask side account.  

Account Bid Side The name of the of the bid side account. 

Buy Member The ID of the member the buying user belongs to.  

Buy User The ID of the buying user. 

Buy/Sell Indicates whether the trade is a buy or sell trade. 

Comb Trade Id If the trade is a part of a combination trade, this field contains the value 
of the Trade Id field of the combination trade that is the source of this 
trade. 

Corresponding Price The corresponding price of the trade. If there is an alternative way to 
express the price of a traded instrument, this value is calculated by the 
ASX 24 Trading Platform. An example is a traded bond where the 
corresponding price is a yield. 

Counter Party Clearing 
Member 

The counterparty member responsible for clearing the order. 

Note: This field is only filled out if the current market transparency 
allows for it. 

Counter Party Member The ID of the counterparty member. 

Note: This field is only filled out if the current market transparency 
allows for it. 

Counter Party Owner Type The owner type of the counterparty side of the trade. 

It can be one of the following: 

 CUSTOMER 

 PRINCIPAL. 

Note: This value is only visible if the current market transparency allows 
for it. 

Counter Party Trading 
Member 

The ID of the counterparty participant's sponsoring member. 

Note: This field is only filled out if the current market transparency 
allows for it. 

Deal Id The ID of the deal this trade is part of. 

Note: A deal is defined as all trades generated by a single event. An 
event is, for example, an incoming order or an uncross. Thus all trades 
resulting from the same event will have the same deal number. 

Id The ID assigned to each individual trade. It is unique both over time and 
within the ASX 24 Trading Platform. 

Is Aggressor The aggressor defines a side of a trade (buy, sell, or both sides). It defines 
if the side is exploiting liquidity in the book. Which side is the aggressor 
depends on trading phase, order type, marketplace-price model, etc. The 
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Column Description 

normal case is that an incoming order (aggressor) hits a resting order in 
the book (passive). 

The following values are possible: 

 No 

 Yes. 

Own Account Information about a user’s own account.  

Own Clearing Member The own member who is responsible for clearing the order. 

Own Info Text Information text for a user’s own side of the trade. 

Own Member The ID of the member that you belong to (your side of the trade).  

Own Message Ref Message text about the trade. 

Own Owner Type This can have one of the following values: 

 CUSTOMER 

 PRINCIPAL. 

Own Private Order Id The ID of an order on the private flow. The ID is unique both over time 
and within the system. 

Own Trading Member The own participant's sponsoring member. 

Own User The ID of the user you belong to. 

Price The price of the trade. 

Qty The volume of an order. 

Receiving Member Counterparty member who receives a copy of the trade report half. 

Reference Trade ID The reference trade ID is used to tie two trades together. It can be used 
to tie related trades together and to connect a busted trade with its 
replacement trade. 

Sell User The ID of the selling user. 

Sub Trade Type The subtypes of trade are: 

 AUCTION - Auction execution 

 AUTO - Deprecated; anything but trade report 

 MANUAL_LAST_AUCTION - Manual set of last auction price 

 MANUAL_LAST_REFERENCE - Manual set of last reference price 

 MANUAL_LAST_TRADE - Manual set of last trade price 

 TRADE_REPORT - Trade report execution 

 TRANSPARENT_TO_TRANSPARENT - Execution of two 
transparent orders. 

Time Of Event The time when the event took place. 

Time of Trade The time for the trade to take place. 

Total Turnover The total turnover for trades executed during the trading day. 
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Column Description 

Total Volume Traded The total volume for trades executed during trading day. 

Tradeable Instrument The name of the tradeable instrument. 

Trade Type The following types of trade are available: 

 BUSTED - A busted trade, that is, a cancelled trade 

 NEW - A new trade 

 TRADE_REPORT_HALF – A half of a trade report (not a complete 
trade). This type is received only on private flows. 

 UPDATED - An update of a trade with the same trade or deal ID 
as the original trade. This type is received only on private flows. 

Update Last Paid The following values are allowed: 

 Yes - The trade is allowed to update LastTradePrice. 

 No - The trade is not allowed to update LastTradePrice. 
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8.24. Trade Reports View 

To open the Trade Reports view, select Trade>Trade Reports. 

 

 

Column Description 

Buy/Sell Indicates whether the trade is a buy or sell trade.  

Member The ID of the member. 

Price The price of the trade. 

Qty The volume of the trade. 

State The trading state of the instrument.  

Time Of Event The time when the event took place. 

Tradeable Instrument The name of the tradeable instrument. 
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8.25. Trade Reports Details Dialogue Box 

 

Column Description 

Hide Empty Rows If selected, only attributes with a value are displayed.  

Account Ask Side The name of the ask side account. 

Account Bid Side The name of the of the bid side account. 

Buy/Sell Indicates whether the trade is a buy or sell trade. 

Buy Member The ID of the member the buying user belongs to.  

Buy User The ID of the buying user. 

Comb Trade Id If the trade is a part of a combination trade, this field contains the 
value of the Trade Id field of the combination trade that is the 
source of this trade. 

Corresponding Price The corresponding price of the trade. If there is an alternative way 
to express the price of a traded instrument, this value is calculated 
by the ASX 24 Trading Platform. An example is a traded bond 
where the corresponding price is a yield. 

Counter Party Clearing Member The counterparty member responsible for clearing the order. 
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Column Description 

Note: This field is only filled out if the current market transparency 
allows for it. 

Counter Party Member The ID of the counterparty member. 

Note: This field is only filled out if the current market transparency 
allows for it. 

Counter Party Owner Type This can have one of the following values: 

 CUSTOMER 

 PRINCIPAL. 

Counter Party Trading Member The ID of the counterparty participant's sponsoring member. 

Note: This field is only completed if the current market 
transparency allows for it. 

Counter Party User The ID of the counterparty user. 

Note: This field is only completed if the current market 
transparency allows for it. 

Deal Id The ID of the deal for the trade. 

Note: A deal is defined as all trades generated by a single event. 
An event is, for example, an incoming order or an uncross. Thus all 
trades resulting from the same event will have the same deal 
number. 

High The day's highest registered price for the tradeable instrument. 

Id The ID assigned to each individual trade. It is unique both over 
time and within the ASX 24 Trading Platform. 

Is Aggressor The aggressor defines a side of a trade (buy, sell, or both sides). It 
defines if the side is exploiting liquidity in the book. Which side is 
aggressor depends on trading phase, order type, marketplace-
price model, etc. The normal case is that an incoming order 
(aggressor) hits a resting order in the book (passive). 

The following values are possible: 

 No 

 Yes. 

Last Auction Price The last recorded auction price for the tradeable instrument.  

Low The day's lowest registered price for the contract. 

Own Account Information about your own account. 

Own Clearing Member The own member who is responsible for clearing the order. 

Own Info Text Information text for your own side of the trade. 

Own Member The ID of the member that you belong to (your side of the trade).  

Own Message Ref Message text about the trade. 
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Column Description 

Own Owner Type This can have one of the following value: 

 CUSTOMER 

 PRINCIPAL. 

Own Private Order Id The ID of an order on the private flow. The ID is unique both over 
time and within the system. 

Own Trading Member The own participant's sponsoring member. 

Own User The ID of the user you belong to. 

Price The price of the trade. 

Qty The volume of the trade. 

Receiving Member Counterparty member who receives a copy of the trade report 
half. 

Reference Trade Id The reference trade ID is used to tie two trades together. It can be 
used to tie related trades together and to connect a busted trade 
with its replacement trade. 

Sell Member The ID of the member that the selling user belongs to. 

Sell User The ID of the selling user. 

Sub Trade Type The subtypes of trade are: 

 AUCTION - Auction execution. 

 AUTO - Deprecated; anything but trade report. 

 MANUAL_LAST_AUCTION - Manual set of last auction 
price. 

 MANUAL_LAST_REFERENCE - Manual set of last reference 
price. 

 MANUAL_LAST_TRADE - Manual set of last trade price. 

 TRADE_REPORT - Trade report execution. 

 TRANSPARENT_TO_TRANSPARENT - Execution of two 
transparent orders. 

Time of Event The time when the event took place. 

Time of Trade The time for the trade to take place. 

Total Turnover The total turnover for trades executed during the trading day. 

Total Volume 

Traded 

The total volume for trades executed during trading day. 

Tradeable Instrument The name of the tradeable instrument. 

Trade Id The ID assigned to each individual trade. It is unique both over 
time and within the ASX 24 Trading Platform. 
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Column Description 

Trade Type The following types of trade are available: 

 BUSTED - A busted trade, that is, a cancelled trade. 

 NEW - A new trade. 

 TRADE_REPORT_HALF - One half of a trade report (not a 
complete trade). This type is received only on private flows. 

 UPDATED - An update of a trade with the same trade ID or 
deal ID as the original trade. This type is received only on 
private flows. 

Update Last Paid The following values are allowed: 

 Yes - The trade is allowed to update LastTradePrice. 

 No - The trade is not allowed to update LastTradePrice. 
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8.26. Update Order Dialogue Box 

To open the Update Order dialogue box, right-click on the required order and select Update Order. 

 

 

The functionality in this dialogue box is the same as in the Enter Order dialogue box. 
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9. Customising the Workspace 

The appearance and contents of ASX Trading Terminal can be customised to suit a user’s requirements. This 
includes customising perspectives and tables. 

9.1. Perspectives 

9.1.1. Opening Perspectives 

When ASX Trading Terminal is started for the first time, the Trading Overview perspective is automatically 
displayed. However when ASX Trading Terminal is started again the following time, the perspective that is 
displayed will be the perspective that was current when ASX Trading Terminal was previously closed. 

Perspectives can be opened via either of the two options listed below. 

1. Select Window > Open Perspective and select the required perspective. 

 

2. Click Open Perspective. 
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3. Select the required perspective, and click OK. 

 

9.1.2. Customising Perspectives 

Displaying Only Perspective Icon 

To display only the perspective icon: 

1. Right-click anywhere on the perspective toolbar. 

2. Click Show Text. 

 

Moving a View 

To move a view, drag and drop the view’s tab to the required location. Note that when a view has been 
moved, ASX Trading Terminal remembers that setting. 

Closing a View 

To close a view, right-click the view tab and select Close, Close Others, and Close All. 

 
 

9.1.3. Creating and Saving a Personal Perspective 

Instead of reconfiguring a perspective, a personal perspective can be created. This perspective can contain 
views that are most frequently used, and can be rearranged as required. Once the required perspective has 
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been created, it can be saved to a specified name. Note that there are various methods for creating a 
personal perspective and that this is only one method that can be used. 

To create and save a personalised perspective: 

1. Add the required views to the desktop. 

2. Move views to the required location by dragging and dropping. Close any views that are not required. 

3. Select Window > Save Perspective As. 

   

4. Enter the required name for the perspective in the Name field, and click OK. 
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9.1.4. Resetting Perspectives 

If views in a perspective have been moved, closed, or opened, the perspective can be reset to its last saved 
appearance. 

To reset a perspective: 

1. Open the required perspective. 

2. Select Window > Reset Perspective. 

This opens the Reset Perspective dialogue box. 

 

3. Click Yes to confirm. 
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9.1.5. Modifying Perspectives 

Perspectives can be renamed or deleted. 

To modify a perspective: 

1. Select Window > Modify Perspectives. 

 

2. Select the required perspective from the list. 

 

3. Click either Delete or Rename. 

4. Click Close.  
Once the required perspectives have been deleted or renamed, click Close. 
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9.1.6. Closing Perspectives 

Perspectives can either be closed individually or all at once. 

 

Note: 

When closing ASX Trading Terminal the current perspective is automatically saved. The 
following time ASX Trading Terminal is opened, it opens at the previously saved perspective. 

 
To close one perspective: 

1. Open the required perspective. 

2. Select Window > Close Perspective or right-click the perspectives name in the perspectives toolbar. 

3. Click Close. 

To close all perspectives select Window > Close All Perspectives. 

9.2. Tables 

Many views contain information in a tabular format. The amount of columns displayed can be specified, as 
well as the ability to sort and copy contents. 

9.2.1. Displaying and Hiding Columns 

In several perspectives and views the required columns can be specified for the table. In some perspectives 
the rows to be displayed can also be specified. 

To display and hide columns: 

1. Click the down arrow of the required view. 

2. Select Choose Columns. 
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3. Select the column name from the Display Columns or Available Columns list and click Add or Remove. 

 To remove a column from a table, click the column’s name in the Display Columns list and click 
Remove. 

 To add a column to the table, click the column’s name in the Available Columns list and click Add.  

 

4. Click OK.  
Once all of the required columns have been added or removed, click OK. 

9.2.2. Moving Columns 

In several perspectives and views, table columns can be moved. Columns can be moved in the table by 
dragging them into the required location. Columns in the table can also be moved using the ASX Trading 
Terminal menus. 

To move a column using the menus: 

1. Click the down arrow in the right corner of the view. 

2. Select Choose Columns. 
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3. Select the column name from the Display Columns list. 

 

 

4. Select Up to move the column to the left in the table, or Down to move the column to the right in the 
table. 

5. Click OK. 
 

9.2.3. Sorting Columns 

Almost all tables can be sorted in alphabetical order according to a specific column. 

 

Note: 

In the Message Tracker perspective the table cannot be sorted. 

 
To sort columns, click the column heading. If there is an up arrow on the heading, the columns will be sorted 
in alphabetical order. To reverse the alphabetical order, click the column heading again. There will now be a 
down arrow displayed. 

 

9.2.4. Optimising Column Widths 

To increase the readability of tables, all column widths can be automatically optimised in a table to fit the 
contents. 
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To optimise column widths: 

1. Click the tab of the required table. 

2. Click the down arrow on the right corner of the tab. 

 

3. Select Optimise Column Widths. 
The columns will be modified to fit the table with the best column spread. 
 

9.2.5. Exporting Data to Excel 

Data can be exported into Excel either as a complete file, or only selected data. 

To export all data to Excel: 

1. Select File > Export > Export All to Excel.  
Alternatively, select the down arrow on the tab toolbar, and select File > Export > Export All to Excel. 
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2. Navigate to the required location for the file to be saved. 

 

3. Click Save. 

 
To export selected data: 

1. Select the row required to be exported from the table. 

2. Select File > Export > Export Selected to Excel. 
Alternatively, select the down arrow on the tab toolbar, and select File > Export > Export Selected to 
Excel. 
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3. Navigate to the required location for the file to be saved. 

 

4. Click Save. 

 

9.2.6. Copying Data from Tables 

In tables with configurable columns (columns that can be set to be visible or hidden), the contents of the 
visible columns can be copied. 

The contents can be copied into various applications for example Excel or an email. Use the paste command, 
CTRL+V, to paste the content into the required application. 

To copy a table: 

1. Click the down arrow to the right of the tab name. 

2. Select Copy > All. 

 

  



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 136/140  
 

To copy rows from a table: 

1. Select the required row from the table. 

2. Click the down arrow to the right of the tab name. 

3. Select Copy > Selected. 

 

9.2.7. Searching in Tables 

In views that display data in tables, specific information can be searched for. 

To search a table: 

1. Click the down arrow in the upper right corner of the tab. 

2. Select Search.  
This opens the Search Table screen. 

  

3. In the Search field, enter the search criteria and click Search.  
The matches are displayed in the frame below the Search field. By clicking a result, the table 
automatically focuses on the selected item. 

 

9.2.8. Changing Properties 

In some table views the font, table appearance, and background colour can be changed as required. 

To change table properties: 



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 137/140  
 

1. Click the down arrow in the upper right corner of the tab, and select Properties. 

 

2. Change the properties as required.  
The colour, font, header and lines can be changed in this screen. 
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Changing Colour 

To change the background (row colour) or foreground (text) colour in tables: 

1. Click the coloured box next to Background/Foreground Colour. This opens the Colour dialogue box.  

2. Select the required colour and click OK. 

 

Custom colours can also be selected by clicking Define Custom Colours. 

Changing Font 

To change the font in a table, click Change. This opens the Font screen where the font can be modified as 
required. Click OK when the required information has been changed. 

 

  



 
 

ASX Trading Terminal User Guide 

 

© Copyright 2023 ASX Operations Pty Limited ABN 42 004 523 782. All rights reserved 2023. 139/140  
 

Changing Headers and Lines 

1. To display the column headers in a table, select Header Visible. 

 

To display the lines in a table, select Lines Visible. 

Both options can be selected to display the headers and the lines. 

2. Click OK when the required options have changed. 
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Disclaimer 

This document provides general information only and may be subject to change at any time without notice. ASX 
Limited (ABN 98 008 624 691) and its related bodies corporate (“ASX”) makes no representation or warranty 
with respect to the accuracy, reliability or completeness of this information. To the extent permitted by law, ASX 
and its employees, officers and contractors shall not be liable for any loss or damage arising in any way, including 
by way of negligence, from or in connection with any information provided or omitted, or from anyone acting or 
refraining to act in reliance on this information. The information in this document is not a substitute for any 
relevant operating rules, and in the event of any inconsistency between this document and the operating rules, 
the operating rules prevail to the extent of the inconsistency. 

ASX Trade Marks 

The trade marks listed below are trade marks of ASX. Where a mark is indicated as registered it is registered in 
Australia and may also be registered in other countries. Nothing contained in this document should be construed 
as being any licence or right to use of any trade mark contained within the document. 

ASX®, ASX Trade® 


